Project

General

Profile

Bug #44063

tox: ImportError: cannot import name 'ensure_text'

Added by Sebastian Wagner 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
dashboard/qa
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Requirement already satisfied: tox in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (3.14.3)
Requirement already satisfied: filelock<4,>=3.0.0 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (3.0.12)
Requirement already satisfied: packaging>=14 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (20.1)
Requirement already satisfied: py<2,>=1.4.17 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (1.8.1)
Requirement already satisfied: importlib-metadata<2,>=0.12; python_version < "3.8" in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (1.5.0)
Requirement already satisfied: toml>=0.9.4 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (0.10.0)
Requirement already satisfied: pluggy<1,>=0.12.0 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (0.13.1)
Requirement already satisfied: virtualenv>=16.0.0 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (20.0.0)
Requirement already satisfied: six<2,>=1.0.0 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from tox) (1.11.0)
Requirement already satisfied: pyparsing>=2.0.2 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from packaging>=14->tox) (2.4.6)
Requirement already satisfied: zipp>=0.5 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from importlib-metadata<2,>=0.12; python_version < "3.8"->tox) (2.2.0)
Requirement already satisfied: appdirs<2,>=1.4.3 in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from virtualenv>=16.0.0->tox) (1.4.3)
Requirement already satisfied: importlib-resources<2,>=1.0; python_version < "3.7" in /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/lib/python3.6/site-packages (from virtualenv>=16.0.0->tox) (1.0.2)
py3 create: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/py3
ERROR: invocation failed (exit code 1), logfile: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/py3/log/py3-0.log
================================== log start ===================================
ERROR:root:ImportError: cannot import name 'ensure_text'

=================================== log end ====================================
ERROR: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 py3 (exited with code 1)
lint create: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/lint
ERROR: invocation failed (exit code 1), logfile: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/lint/log/lint-0.log
================================== log start ===================================
ERROR:root:ImportError: cannot import name 'ensure_text'

=================================== log end ====================================
ERROR: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 lint (exited with code 1)
check create: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/check
ERROR: invocation failed (exit code 1), logfile: /home/jenkins-build/build/workspace/ceph-pull-requests/src/pybind/mgr/dashboard/.tox/check/log/check-0.log
================================== log start ===================================
ERROR:root:ImportError: cannot import name 'ensure_text'

=================================== log end ====================================
ERROR: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 check (exited with code 1)
___________________________________ summary ____________________________________
ERROR:   py3: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 py3 (exited with code 1)
ERROR:   lint: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 lint (exited with code 1)
ERROR:   check: InvocationError for command /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 -m virtualenv --no-download --python /home/jenkins-build/build/workspace/ceph-pull-requests/build/mgr-dashboard-virtualenv/bin/python3.6 check (exited with code 1)

https://jenkins.ceph.com/job/ceph-pull-requests/44319/consoleFull#-14159901736733401c-e9d0-4737-9832-6594c5da0afa
https://jenkins.ceph.com/job/ceph-pull-requests/44308/consoleFull#-156140668e840cee4-f4a4-4183-81dd-42855615f2c1


Related issues

Related to mgr - Bug #44802: mgr/dashboard: ceph-api-nightly-nautilus-backend failure "ImportError: cannot import name ensure_str" Resolved

History

#1 Updated by Sebastian Wagner 8 months ago

  • Description updated (diff)

#2 Updated by Sebastian Wagner 8 months ago

  • Priority changed from Immediate to Urgent

urgent, as it seems to be only reproducible on bionic

#4 Updated by Sebastian Wagner 8 months ago

Seems to be the first one:

https://jenkins.ceph.com/job/ceph-pull-requests/44300/

Build #44300 (10.02.2020 09:40:47)

#5 Updated by Kefu Chai 8 months ago

  • Assignee set to Kefu Chai

#6 Updated by Kefu Chai 8 months ago

  • Status changed from New to Fix Under Review

#7 Updated by Kefu Chai 8 months ago

  • Pull request ID set to 33185

#8 Updated by Kefu Chai 8 months ago

  • Status changed from Fix Under Review to Resolved

#9 Updated by Laura Paduano 7 months ago

  • Related to Bug #44802: mgr/dashboard: ceph-api-nightly-nautilus-backend failure "ImportError: cannot import name ensure_str" added

Also available in: Atom PDF