Project

General

Profile

Bug #43869

mgr/dashboard: Teuthology test failure "test_pwd_expiration_date_update (tasks.mgr.dashboard.test_user.UserTest)"

Added by Laura Paduano 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:
Crash signature:

Description

2020-01-28T22:10:14.526 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700 20 mgrc handle_mgr_map mgrmap(e 635) v1
2020-01-28T22:10:14.526 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700  4 mgrc handle_mgr_map Got map version 635
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700  4 mgrc handle_mgr_map Active mgr is now [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428]
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700  4 mgrc reconnect Starting new session with [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428]
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 0x7f9fe805c860 unknown :-1 s=NONE pgs=0 cs=0 l=1 rx=0 tx=0).connect
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa00d7e8700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 0x7f9fe805c860 unknown :-1 s=BANNER_CONNECTING pgs=0 cs=0 l=1 rx=0 tx=0)._handle_peer_banner_payload supported=0 required=0
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa0067fc700  1 -- 172.21.15.74:0/867417953 <== mon.1 v2:172.21.15.151:3300/0 5 ==== osd_map(343..343 src has 1..343) v4 ==== 25186+0+0 (secure 0 0 0) 0x7f9ff8070c40 con 0x7fa0080a8f60
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.495+0000 7fa00d7e8700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 0x7f9fe805c860 crc :-1 s=READY pgs=69 cs=0 l=1 rx=0 tx=0).ready entity=mgr.22168 client_cookie=0 server_cookie=0 in_seq=0 out_seq=0
2020-01-28T22:10:14.527 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.503+0000 7fa00dfe9700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] conn(0x7fa0080a8f60 0x7fa0080a79f0 secure :-1 s=THROTTLE_DONE pgs=4019 cs=0 l=1 rx=0x7f9ffc001e90 tx=0x7f9ffc000e90).handle_read_frame_epilogue_main read frame epilogue bytes=32
2020-01-28T22:10:14.528 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.503+0000 7fa0067fc700  1 -- 172.21.15.74:0/867417953 <== mon.1 v2:172.21.15.151:3300/0 6 ==== mon_command_ack([{"prefix": "get_command_descriptions"}]=0  v0) v1 ==== 72+0+117303 (secure 0 0 0) 0x7f9ff8056a40 con 0x7fa0080a8f60
2020-01-28T22:10:14.671 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:14.667+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 --> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] -- mon_command({"prefix": "log", "logtext": ["Ended test tasks.mgr.dashboard.test_user.UserTest.test_pwd_expiration_date_update"]} v 0) v1 -- 0x7fa00806a8d0 con 0x7fa0080a8f60
2020-01-28T22:10:15.402 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.395+0000 7fa00dfe9700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] conn(0x7fa0080a8f60 0x7fa0080a79f0 secure :-1 s=THROTTLE_DONE pgs=4019 cs=0 l=1 rx=0x7f9ffc001e90 tx=0x7f9ffc000e90).handle_read_frame_epilogue_main read frame epilogue bytes=32
2020-01-28T22:10:15.403 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.395+0000 7fa0067fc700  1 -- 172.21.15.74:0/867417953 <== mon.1 v2:172.21.15.151:3300/0 7 ==== mon_command_ack([{"prefix": "log", "logtext": ["Ended test tasks.mgr.dashboard.test_user.UserTest.test_pwd_expiration_date_update"]}]=0  v1899) v1 ==== 149+0+0 (secure 0 0 0) 0x7f9ff8057850 con 0x7fa0080a8f60
2020-01-28T22:10:15.406 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700 10 mgrc shutdown
2020-01-28T22:10:15.406 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 msgr2=0x7f9fe805c860 crc :-1 s=STATE_CONNECTION_ESTABLISHED l=1).mark_down
2020-01-28T22:10:15.406 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 0x7f9fe805c860 crc :-1 s=READY pgs=69 cs=0 l=1 rx=0 tx=0).stop
2020-01-28T22:10:15.406 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 >> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] conn(0x7fa0080a8f60 msgr2=0x7fa0080a79f0 secure :-1 s=STATE_CONNECTION_ESTABLISHED l=1).mark_down
2020-01-28T22:10:15.406 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] conn(0x7fa0080a8f60 0x7fa0080a79f0 secure :-1 s=READY pgs=4019 cs=0 l=1 rx=0x7f9ffc001e90 tx=0x7f9ffc000e90).stop
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 shutdown_connections
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.74:6802/82428,v1:172.21.15.74:6803/82428] conn(0x7f9fe805a350 0x7f9fe805c860 unknown :-1 s=CLOSED pgs=69 cs=0 l=1 rx=0 tx=0).stop
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 --2- 172.21.15.74:0/867417953 >> [v2:172.21.15.151:3300/0,v1:172.21.15.151:6789/0] conn(0x7fa0080a8f60 0x7fa0080a79f0 unknown :-1 s=CLOSED pgs=4019 cs=0 l=1 rx=0 tx=0).stop
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 >> 172.21.15.74:0/867417953 conn(0x7fa008125870 msgr2=0x7fa0080a98e0 unknown :-1 s=STATE_NONE l=0).mark_down
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 shutdown_connections
2020-01-28T22:10:15.407 INFO:teuthology.orchestra.run.smithi074.stderr:2020-01-28T22:10:15.399+0000 7fa00e7ea700  1 -- 172.21.15.74:0/867417953 wait complete.
2020-01-28T22:10:15.421 INFO:tasks.cephfs_test_runner:
2020-01-28T22:10:15.421 INFO:tasks.cephfs_test_runner:======================================================================
2020-01-28T22:10:15.421 INFO:tasks.cephfs_test_runner:ERROR: test_pwd_expiration_date_update (tasks.mgr.dashboard.test_user.UserTest)
2020-01-28T22:10:15.422 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2020-01-28T22:10:15.422 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2020-01-28T22:10:15.422 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-laura-testing-32708/qa/tasks/mgr/dashboard/test_user.py", line 379, in test_pwd_expiration_date_update
2020-01-28T22:10:15.422 INFO:tasks.cephfs_test_runner:    self.login('user1', 'mypassword10#')
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-laura-testing-32708/qa/tasks/mgr/dashboard/helper.py", line 87, in login
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:    cls.logout()
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-laura-testing-32708/qa/tasks/mgr/dashboard/helper.py", line 95, in logout
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:    cls._post('/api/auth/logout')
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-laura-testing-32708/qa/tasks/mgr/dashboard/helper.py", line 234, in _post
2020-01-28T22:10:15.423 INFO:tasks.cephfs_test_runner:    cls._request(url, 'POST', data, params)
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-laura-testing-32708/qa/tasks/mgr/dashboard/helper.py", line 189, in _request
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:    verify=False, headers=headers)
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/sessions.py", line 581, in post
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:    return self.request('POST', url, data=data, json=json, **kwargs)
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/sessions.py", line 533, in request
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:    resp = self.send(prep, **send_kwargs)
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/sessions.py", line 646, in send
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:    r = adapter.send(request, **kwargs)
2020-01-28T22:10:15.424 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/adapters.py", line 498, in send
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:    raise ConnectionError(err, request=request)
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:ConnectionError: ('Connection aborted.', BadStatusLine("''",))
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:Ran 235 tests in 2239.939s
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:
2020-01-28T22:10:15.425 INFO:tasks.cephfs_test_runner:FAILED (errors=1)


Related issues

Related to mgr - Bug #44256: Test failure: test_create_user_with_pwd_expiration_date (tasks.mgr.dashboard.test_user.UserTest) Closed

History

#1 Updated by Laura Paduano 9 months ago

  • Description updated (diff)

#2 Updated by Sage Weil 8 months ago

/a/sage-2020-03-05_01:26:16-rados:dashboard-wip-sage2-testing-2020-03-04-1543-distro-basic-smithi/4826168

#3 Updated by Volker Theile 8 months ago

  • Status changed from New to In Progress
  • Assignee set to Volker Theile
  • Pull request ID set to 33743

#4 Updated by Volker Theile 8 months ago

This issue has a strange behavior. The REST API seems to be away when doing a logout. Adding various GET request right before the logout instead are processed correctly. I really have no idea what is going on here because i can not reproduce this by executing the various steps manually with Postman.

#5 Updated by Lenz Grimmer 8 months ago

  • Status changed from In Progress to Resolved
  • Target version set to v15.0.0

#6 Updated by Volker Theile 7 months ago

  • Related to Feature #22168: The RGW Admin OPS is missing the ability to filter for e.g. buckets and users added

#7 Updated by Volker Theile 7 months ago

  • Related to deleted (Feature #22168: The RGW Admin OPS is missing the ability to filter for e.g. buckets and users)

#8 Updated by Volker Theile 7 months ago

  • Related to Bug #44256: Test failure: test_create_user_with_pwd_expiration_date (tasks.mgr.dashboard.test_user.UserTest) added

Also available in: Atom PDF