Project

General

Profile

Bug #43768

multisite checkpoint failures in three-zone-plus-pubsub.yaml

Added by Casey Bodley 6 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
% Done:

0%

Source:
Tags:
multisite
Backport:
nautilus octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:


Related issues

Copied to rgw - Backport #45055: octopus: multisite checkpoint failures in three-zone-plus-pubsub.yaml Rejected
Copied to rgw - Backport #45056: nautilus: multisite checkpoint failures in three-zone-plus-pubsub.yaml Resolved

History

#1 Updated by Sage Weil 6 months ago

  • Priority changed from Normal to Urgent

#2 Updated by Sage Weil 6 months ago

  • Status changed from New to In Progress
  • Assignee set to Casey Bodley

#3 Updated by Sage Weil 6 months ago

  • Target version set to v15.0.0

#4 Updated by Casey Bodley 5 months ago

It looks like this is a bug with the test suite, and how it does checkpoints when a pubsub zone is present.

#5 Updated by Casey Bodley 5 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 32941

#6 Updated by Yuval Lifshitz 5 months ago

fix in PR #32941
exposed another issue with the multisite pubsub tests: http://qa-proxy.ceph.com/teuthology/cbodley-2020-01-28_20:33:35-rgw:multisite-wip-cbodley-testing2-distro-basic-smithi/4715065/teuthology.log

will be fixed separately

#7 Updated by Yuval Lifshitz 5 months ago

the pubsub failures are addressed here: https://github.com/ceph/ceph/pull/33049

#9 Updated by Casey Bodley 3 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to nautilus octopus

#10 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #45055: octopus: multisite checkpoint failures in three-zone-plus-pubsub.yaml added

#11 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #45056: nautilus: multisite checkpoint failures in three-zone-plus-pubsub.yaml added

#12 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF