Project

General

Profile

Bug #43595

mgr/dashboard: user with no config-opt permissions getting 403 redirection

Added by Alfonso MH about 1 month ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/UI
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

User with no config-opt read permission gets 403 redirection
when navigating to '/' path.

The cause is PrometheusService (in NavigationComponent) trying to retrieve
settings when user doesn't have appropriate permissions.


Related issues

Copied to mgr - Backport #43811: nautilus: mgr/dashboard: user with no config-opt permissions getting 403 redirection Resolved

History

#1 Updated by Alfonso MH about 1 month ago

  • Description updated (diff)
  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 32638

#2 Updated by Lenz Grimmer 25 days ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler 25 days ago

  • Copied to Backport #43811: nautilus: mgr/dashboard: user with no config-opt permissions getting 403 redirection added

#4 Updated by Nathan Cutler 11 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF