Project

General

Profile

Bug #43254

mgr/dashboard: Jenkins dashboard test failures due to "Error: Angular could not be found on the page"

Added by Laura Paduano about 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Testing & QA
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The dashboard e2e test Jenkins job currently fails during the frontend build (run-frontend-e2e-script.sh execution), this affects PRs targeting master.
Error message:

[12:10:39] I/file_manager - creating folder /home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium
[12:10:39] I/config_source - curl -o/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium/standalone-response.xml https://selenium-release.storage.googleapis.com/
[12:10:39] I/config_source - curl -o/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium/chrome-response.xml https://chromedriver.storage.googleapis.com/
[12:10:39] I/downloader - curl -o/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium/selenium-server-standalone-3.141.59.jar https://selenium-release.storage.googleapis.com/3.141/selenium-server-standalone-3.141.59.jar
[12:10:39] I/downloader - curl -o/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium/chromedriver_79.0.3945.79.zip https://chromedriver.storage.googleapis.com/79.0.3945.36/chromedriver_linux64.zip
[12:10:40] I/update - chromedriver: unzipping chromedriver_79.0.3945.79.zip
[12:10:40] I/update - chromedriver: setting permissions to 0755 for /home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/node_modules/webdriver-manager/selenium/chromedriver_79.0.3945.79
[12:10:43] I/launcher - Running 1 instances of WebDriver
[12:10:43] I/direct - Using ChromeDriver directly...
Activated Protractor Screenshoter Plugin, ver. 0.10.3 (c) 2016 - 2019 Andrej Zachar and contributors
[12:10:54] E/protractor - Could not find Angular on page https://ceph-builders:41091/#/login : retries looking for angular exceeded
[12:10:54] E/launcher - Error: Error: Angular could not be found on the page https://ceph-builders:41091/#/login. If this is not an Angular application, you may need to turn off waiting for Angular.
                          Please see 
                          https://github.com/angular/protractor/blob/master/docs/timeouts.md#waiting-for-angular-on-page-load
    at executeAsyncScript_.then (/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend/node_modules/protractor/built/browser.js:720:27)
    at process._tickCallback (internal/process/next_tick.js:68:7)
[12:10:54] E/launcher - Process exited with error code 100
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! ceph-dashboard@0.0.0 e2e:ci: `npm run env_build && npm run e2e:update && ng e2e --dev-server-target --webdriverUpdate=false`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the ceph-dashboard@0.0.0 e2e:ci script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jenkins-build/.npm/_logs/2019-12-11T12_10_54_260Z-debug.log

- https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/2729
- https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/2730
- https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/2727
- https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/2725


Related issues

Copied to Dashboard - Backport #43302: nautilus: mgr/dashboard: Jenkins dashboard test failures due to "Error: Angular could not be found on the page" Resolved

History

#1 Updated by Kiefer Chang about 4 years ago

This can be reproduced locally after upgrading Chrome to version `79.0.3945.79`.
If we do not tear down the vstart cluster, the dashboard can still be reached after the error.
I had version `78.0.3904.87` installed before the upgrade and I couldn't see the issue.

By removing the `--webdriverUpdate=false` option (
https://github.com/ceph/ceph/blob/c4d12bfef8fa9d06a77186ea3a401e0a4a795025/src/pybind/mgr/dashboard/frontend/package.json#L37), the e2e tests will be performed. (with web driver chromedriver_78.0.3904.105.zip).

#2 Updated by Laura Paduano about 4 years ago

Kiefer Chang wrote:

This can be reproduced locally after upgrading Chrome to version `79.0.3945.79`.

I locally updated to google-chrome-stable v 79.0.3945.79 and now getting the same error as in Jenkins.

If we do not tear down the vstart cluster, the dashboard can still be reached after the error.
I had version `78.0.3904.87` installed before the upgrade and I couldn't see the issue.

By removing the `--webdriverUpdate=false` option (
https://github.com/ceph/ceph/blob/c4d12bfef8fa9d06a77186ea3a401e0a4a795025/src/pybind/mgr/dashboard/frontend/package.json#L37), the e2e tests will be performed. (with web driver chromedriver_78.0.3904.105.zip).

Locally tested it and I'm able to run the tests again.

#3 Updated by Nathan Cutler about 4 years ago

  • Status changed from New to Pending Backport
  • Backport set to nautilus
  • Pull request ID set to 32224

#4 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Fix Under Review

#5 Updated by Nathan Cutler about 4 years ago

  • Assignee set to Tiago Melo

#6 Updated by Kiefer Chang about 4 years ago

  • Status changed from Fix Under Review to Resolved

#7 Updated by Nathan Cutler about 4 years ago

  • Status changed from Resolved to Pending Backport

#8 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #43302: nautilus: mgr/dashboard: Jenkins dashboard test failures due to "Error: Angular could not be found on the page" added

#9 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

#10 Updated by Ernesto Puerta almost 3 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 151 to Testing & QA

Also available in: Atom PDF