Project

General

Profile

Bug #42776

mgr/dashboard: Pool rename edit form does not return but the pool gets renamed

Added by Ernesto Puerta 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Category:
dashboard/pools
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Reproducer:
- Select existing pool (e.g.: "rbd") and click "Edit"
- Change pool name from "rbd" to something else (e.g: "rbd2").
- Click on bottom-right button "Edit Pool".

Expected:
- The form closes and the pool gets renamed.

Actual outcome:
- The form hangs, and a floating error message appears (404 - Not Found. The path 'No such pool' was not found.)

The exception traceback is as follows:

...  0 mgr[dashboard] Error while calling Task(ns=pool/edit, md={'pool_name': 'rbd2'})
Traceback (most recent call last):
  File "/ceph/src/pybind/mgr/dashboard/tools.py", line 546, in _run
    val = self.task.fn(*self.task.fn_args, **self.task.fn_kwargs)
  File "/ceph/src/pybind/mgr/dashboard/controllers/pool.py", line 87, in set
    self._wait_for_pgs(pool_name)
  File "/ceph/src/pybind/mgr/dashboard/controllers/pool.py", line 176, in _wait_for_pgs
    current_pool = cls._get(pool_name)

Marked as regression, as it does not happen in nautilus (v14.2.4@cb8144184d).
  File "/ceph/src/pybind/mgr/dashboard/controllers/pool.py", line 68, in _get
    raise cherrypy.NotFound('No such pool')
cherrypy._cperror.NotFound: (404, "The path 'No such pool' was not found.")

pool-rename-error.gif View (631 KB) Lenz Grimmer, 11/13/2019 11:24 AM

History

#1 Updated by Ernesto Puerta 4 months ago

  • Description updated (diff)
  • Target version set to v15.0.0

#2 Updated by Stephan Müller 4 months ago

  • Assignee set to Stephan Müller

#3 Updated by Lenz Grimmer 4 months ago

Here's a screen capture of how this looks like in the UI:

#4 Updated by Stephan Müller 4 months ago

  • Status changed from New to In Progress

#5 Updated by Stephan Müller 4 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31617

#6 Updated by Kefu Chai 3 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF