Project

General

Profile

Bug #42023

install-deps.sh not support aarch64

Added by andy qi 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
build,install-deps.sh
Backport:
nautilus, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

because of hard code in script file ,install-deps.sh script create epel repo not support aarch64

below is part of the script at line 370:

$SUDO yum-config-manager --add-repo https://dl.fedoraproject.org/pub/epel/$MAJOR_VERSION/x86_64/
$SUDO yum install --nogpgcheck -y epel-release

Related issues

Copied to Ceph - Backport #42070: nautilus: install-deps.sh not support aarch64 Resolved
Copied to Ceph - Backport #42071: mimic: install-deps.sh not support aarch64 Resolved

History

#1 Updated by Nathan Cutler 5 months ago

  • Status changed from New to In Progress
  • Assignee set to Nathan Cutler

#2 Updated by Nathan Cutler 5 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 30557

#3 Updated by Nathan Cutler 5 months ago

  • Backport set to nautilus, mimic

backport will need a1a3e7960cf2c792ac8c9c71e68caa0ebada8933 as well

#4 Updated by Nathan Cutler 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #42070: nautilus: install-deps.sh not support aarch64 added

#6 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #42071: mimic: install-deps.sh not support aarch64 added

#7 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF