Project

General

Profile

Bug #38820

ERROR: test_disable (tasks.mgr.dashboard.test_mgr_module.MgrModuleTelemetryTest)

Added by Sage Weil 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
dashboard/qa
Target version:
Start date:
03/19/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:======================================================================
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:ERROR: test_disable (tasks.mgr.dashboard.test_mgr_module.MgrModuleTelemetryTest)
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sage3-testing-2019-03-19-0529/qa/tasks/mgr/dashboard/test_mgr_module.py", line 175, in test_disable
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:    self.wait_until_rest_api_accessible()
2019-03-19T22:35:30.577 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sage3-testing-2019-03-19-0529/qa/tasks/mgr/dashboard/test_mgr_module.py", line 33, in wait_until_rest_api_accessible
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:    self.wait_until_true(_check_connection, timeout=20, period=2)
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sage3-testing-2019-03-19-0529/qa/tasks/ceph_test_case.py", line 164, in wait_until_true
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:    raise RuntimeError("Timed out after {0}s".format(elapsed))
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:RuntimeError: Timed out after 20s
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:Ran 157 tests in 1565.072s
2019-03-19T22:35:30.578 INFO:tasks.cephfs_test_runner:
2019-03-19T22:35:30.579 INFO:tasks.cephfs_test_runner:FAILED (errors=1, skipped=1)

/a/sage-2019-03-19_18:36:56-rados-wip-sage3-testing-2019-03-19-0529-distro-basic-smithi/3747561

Related issues

Copied to mgr - Backport #38974: nautilus: ERROR: test_disable (tasks.mgr.dashboard.test_mgr_module.MgrModuleTelemetryTest) Resolved

History

#1 Updated by Neha Ojha 5 months ago

/a/nojha-2019-03-26_00:22:37-rados-wip-21174-2-distro-basic-smithi/3772849/

#2 Updated by Volker Theile 5 months ago

  • Pull request ID set to 27187

#3 Updated by Volker Theile 5 months ago

Can not reproduce this in my local vstart environment. Maybe the timeout value of 20sec wasn't enough, so i increased it to 30sec.

#4 Updated by Lenz Grimmer 5 months ago

  • Category set to dashboard/qa
  • Status changed from Verified to Need Review
  • Assignee set to Volker Theile
  • Target version set to v15.0.0
  • Backport set to nautilus

#5 Updated by Sage Weil 5 months ago

/a/sage-2019-03-26_03:35:19-rados-wip-sage2-testing-2019-03-25-1934-distro-basic-smithi/3774002

#6 Updated by Volker Theile 5 months ago

After checking the test parameters, i found out that the test uses two Mgr. Maybe that's the reason why the wait_until_rest_api_accessible() function fails, though the log shows that both webserver are running.

2019-03-26T14:11:54.180 INFO:tasks.ceph.mgr.z.smithi173.stderr:[26/Mar/2019:14:11:54] ENGINE Serving on http://:::7791
2019-03-26T14:11:54.180 INFO:tasks.ceph.mgr.z.smithi173.stderr:[26/Mar/2019:14:11:54] ENGINE Bus STARTED
2019-03-26T14:11:54.220 INFO:tasks.ceph.mgr.y.smithi173.stderr:[26/Mar/2019:14:11:54] ENGINE Serving on http://:::7790
2019-03-26T14:11:54.220 INFO:tasks.ceph.mgr.y.smithi173.stderr:[26/Mar/2019:14:11:54] ENGINE Bus STARTED

I reduced this to one Mgr because the tests do not require this nor test a module failover.

#7 Updated by Sage Weil 5 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #38974: nautilus: ERROR: test_disable (tasks.mgr.dashboard.test_mgr_module.MgrModuleTelemetryTest) added

#9 Updated by Tatjana Dehler 5 months ago

  • Status changed from Pending Backport to Resolved

#10 Updated by Neha Ojha 4 months ago

This still fails in nautilus.

2019-04-10T21:21:47.615 INFO:tasks.cephfs_test_runner:======================================================================
2019-04-10T21:21:47.615 INFO:tasks.cephfs_test_runner:ERROR: test_disable (tasks.mgr.dashboard.test_mgr_module.MgrModuleTelemetryTest)
2019-04-10T21:21:47.615 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-04-10T21:21:47.616 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-04-10T21:21:47.616 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-yuri6-testing-2019-04-10-1541-nautilus/qa/tasks/mgr/dashboard/test_mgr_module.py", line 179, in test_disable
2019-04-10T21:21:47.616 INFO:tasks.cephfs_test_runner:    self.wait_until_rest_api_accessible()
2019-04-10T21:21:47.616 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-yuri6-testing-2019-04-10-1541-nautilus/qa/tasks/mgr/dashboard/test_mgr_module.py", line 35, in wait_until_rest_api_accessible
2019-04-10T21:21:47.616 INFO:tasks.cephfs_test_runner:    self.wait_until_true(_check_connection, timeout=30)
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-yuri6-testing-2019-04-10-1541-nautilus/qa/tasks/ceph_test_case.py", line 164, in wait_until_true
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:    raise RuntimeError("Timed out after {0}s".format(elapsed))
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:RuntimeError: Timed out after 30s
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:Ran 157 tests in 1638.004s
2019-04-10T21:21:47.617 INFO:tasks.cephfs_test_runner:
2019-04-10T21:21:47.618 INFO:tasks.cephfs_test_runner:FAILED (errors=1)

/a/yuriw-2019-04-10_19:35:08-rados-wip-yuri6-testing-2019-04-10-1541-nautilus-distro-basic-smithi/3831240/

Also available in: Atom PDF