Project

General

Profile

Bug #37701

mgr/dashboard: Buggy data table search field

Added by Volker Theile 11 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/general
Target version:
Start date:
12/18/2018
Due date:
% Done:

0%

Source:
Development
Tags:
dashboard, usability
Backport:
nautilus
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The search field has a strange behaviour, it does not hide rows when you enter characters that aren't used in the text of the marked columns.

search.gif View (34.4 KB) Volker Theile, 12/18/2018 12:56 PM


Related issues

Copied to mgr - Backport #39370: nautilus: mgr/dashboard: Buggy data table search field Resolved

History

#1 Updated by Lenz Grimmer 10 months ago

  • Tags set to dashboard, usability

#2 Updated by Stephan Müller 10 months ago

The characters that are entered are in included in the columns, that's why the rows aren't hiding. A solution would be only to search the columns if ':' is included in the search pattern.

#3 Updated by Stephan Müller 10 months ago

  • Assignee set to Stephan Müller

#4 Updated by Lenz Grimmer 10 months ago

Stephan Müller wrote:

The characters that are entered are in included in the columns, that's why the rows aren't hiding. A solution would be only to search the columns if ':' is included in the search pattern.

What exactly do you mean by "included in the columns"? The column names (the "table headers")? This would be irritating. I'd assume that entering search term without specifying a column would show only the matching data rows.

#5 Updated by Volker Theile 10 months ago

The problem is that if you type a character like 'a' or 'm' that is not included in the current selected column (here the text 'hot') NOR anywhere else in the complete data of the displayed row the row is not hidden. All available columns of the table are shown. If you type 'p' the row is hidden as expected because this character is not available in 'Name' nor any other column.

#6 Updated by Stephan Müller 8 months ago

  • Status changed from New to In Progress

#7 Updated by Stephan Müller 8 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 27438

#8 Updated by Lenz Grimmer 7 months ago

  • Status changed from Need Review to Pending Backport
  • Target version changed from v14.0.0 to v15.0.0
  • Backport set to nautilus

#9 Updated by Lenz Grimmer 7 months ago

  • Tags set to usability

#11 Updated by Stephan Müller 7 months ago

  • Copied to Backport #39370: nautilus: mgr/dashboard: Buggy data table search field added

#12 Updated by Lenz Grimmer 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF