Project

General

Profile

Bug #35907

mgr/dashboard: Progress bar does not stop in TableKeyValueComponent

Added by Volker Theile about 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
General
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If the autoReload function is disabled in a data table, e.g Pools, then the progress bar in the data table of the details page does not stop spinning.

screenshot.gif View (108 KB) Volker Theile, 09/10/2018 01:00 PM


Related issues

Copied to Dashboard - Backport #35925: mimic: mgr/dashboard: Progress bar does not stop in TableKeyValueComponent Resolved

History

#1 Updated by Volker Theile about 4 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Volker Theile about 4 years ago

The problem was that even if only the data to be displayed was specified via data='xyz' the fetchEvent of the TableComponent was subscribed. Therefore, the loading indicator of the data table was set automatically. The fetchEvent of the TableComponent is now only subscribed if there is a signer of the TableKeyValueComponent.

#3 Updated by Volker Theile about 4 years ago

  • Affected Versions v13.2.2 added

#4 Updated by Lenz Grimmer about 4 years ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to mimic

#5 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #35925: mimic: mgr/dashboard: Progress bar does not stop in TableKeyValueComponent added

#6 Updated by Lenz Grimmer over 3 years ago

  • Pull request ID set to 24016

#7 Updated by Lenz Grimmer over 3 years ago

  • Status changed from Pending Backport to Resolved

#8 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General

Also available in: Atom PDF