Project

General

Profile

Bug #3571

MOSDPGCreate is unconditionally generated at max frequency by monitors

Added by Greg Farnum over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
Monitor
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Sam noticed today that his OSDs were getting an empty MOSDPGCreate message every 30 or 60 seconds. I looked briefly through the code and it turns out that if the OSD exists in the creating_pgs_by_osd map, then it gets a message. But that map is never cleared of OSDs, only of PGs.
Fix please!

Associated revisions

Revision bc6f7268 (diff)
Added by Joao Eduardo Luis over 7 years ago

mon: PGMonitor: erase entries from 'creating_pgs_by_osd' when set is empty

This patch avoids sending empty MOSDPGCreate's every tick.

Fixes: #3571

Signed-off-by: Joao Eduardo Luis <>

History

#1 Updated by Joao Eduardo Luis over 7 years ago

Proposed fix on wip-3571 commit 5d9decaa7118ec7a3ce152ecd29bd6120e1a9078

#2 Updated by Joao Eduardo Luis over 7 years ago

  • Status changed from New to 7

#3 Updated by Sage Weil over 7 years ago

  • Status changed from 7 to Resolved

Also available in: Atom PDF