Project

General

Profile

Bug #23585

osd: safe_timer segfault

Added by Alex Gorbachev over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

[117735.930255] safe_timer[52573]: segfault at 561500001000 ip 00007f156d774ccb sp 00007f15668c1f70 error 4 in libgcc_s.so.1[7f156d766000+16000]

Core dump at https://drive.google.com/open?id=1x_0p9s9JkQ1zo-LCx6mHxm0DQO5sc1UA

ceph-osd.297.log.gz - OSD log (69.7 KB) Alex Gorbachev, 04/08/2018 06:35 AM


Related issues

Related to RADOS - Bug #23431: OSD Segmentation fault in thread_name:safe_timer Duplicate 03/21/2018
Duplicates RADOS - Bug #23352: osd: segfaults under normal operation Resolved 03/14/2018

History

#1 Updated by Patrick Donnelly over 3 years ago

  • Project changed from Ceph to bluestore
  • Subject changed from Another Bluestore segfault to bluestore: another segfault
  • Description updated (diff)

#2 Updated by jianpeng ma over 3 years ago

https://drive.google.com/open?id=1x_0p9s9JkQ1zo-LCx6mHxm0DQO5sc1UA too larger about(1.2G). And ceph-osd.297.log.gz didn't contain any stack info.

#3 Updated by Sergey Malinin over 3 years ago

Got segfault in safe_timer too. Got it just once so can not provide more info at the moment.

2018-04-03 05:53:07.773291 7f664415c700 -1 ** Caught signal (Segmentation fault) *
in thread 7f664415c700 thread_name:safe_timer

ceph version 12.2.4 (52085d5249a80c5f5121a76d6288429f35e4e77b) luminous (stable)
1: (()+0xa74234) [0x557137a61234]
2: (()+0x11390) [0x7f664bccd390]
3: (SafeTimer::timer_thread()+0x44f) [0x557137aa098f]
4: (SafeTimerThread::entry()+0xd) [0x557137aa1d9d]
5: (()+0x76ba) [0x7f664bcc36ba]
6: (clone()+0x6d) [0x7f664ad3a41d]
NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

#4 Updated by Josh Durgin over 3 years ago

#5 Updated by Josh Durgin over 3 years ago

  • Project changed from bluestore to RADOS
  • Subject changed from bluestore: another segfault to osd: safe_timer segfault
  • Status changed from New to Triaged

#6 Updated by Josh Durgin over 3 years ago

  • Related to Bug #23431: OSD Segmentation fault in thread_name:safe_timer added

#7 Updated by Josh Durgin over 3 years ago

  • Related to Bug #23352: osd: segfaults under normal operation added

#8 Updated by Brad Hubbard over 3 years ago

Alex,

Can we close this bug also as a duplicate of 23352?

#9 Updated by Alex Gorbachev over 3 years ago

Hi Brad, sure, thanks.

#10 Updated by Brad Hubbard over 3 years ago

  • Status changed from Triaged to Duplicate

Duplicate of 23352

#11 Updated by Brad Hubbard over 3 years ago

  • Related to deleted (Bug #23352: osd: segfaults under normal operation)

#12 Updated by Brad Hubbard over 3 years ago

  • Duplicated by Bug #23352: osd: segfaults under normal operation added

#13 Updated by Brad Hubbard over 3 years ago

  • Duplicated by deleted (Bug #23352: osd: segfaults under normal operation)

#14 Updated by Brad Hubbard over 3 years ago

  • Duplicates Bug #23352: osd: segfaults under normal operation added

Also available in: Atom PDF