Project

General

Profile

Bug #22655

rgw: Location element not returned correctly from CompleteMultipartUpload

Added by Matt Benjamin almost 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Support
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Per https://docs.aws.amazon.com/AmazonS3/latest/API/mpUploadComplete.html, the <Location> element in the HTTP response body should contain a (or the) HTTP URI "that identifies the newly created object."

RGW has not been doing this.


Related issues

Copied to rgw - Backport #22905: luminous: rgw: Location element not returned correctly from CompleteMultipartUpload Resolved
Copied to rgw - Backport #24944: jewel: rgw: Location element not returned correctly from CompleteMultipartUpload Rejected

History

#1 Updated by Matt Benjamin almost 3 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Yehuda Sadeh almost 3 years ago

  • Status changed from Fix Under Review to 7

#4 Updated by Matt Benjamin over 2 years ago

  • Status changed from 7 to Pending Backport

#5 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #22905: luminous: rgw: Location element not returned correctly from CompleteMultipartUpload added

#6 Updated by Nathan Cutler over 2 years ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Nathan Cutler over 2 years ago

  • Status changed from Resolved to Pending Backport
  • Target version deleted (v13.0.0)
  • Backport changed from luminous to luminous,jewel

#8 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #24944: jewel: rgw: Location element not returned correctly from CompleteMultipartUpload added

#9 Updated by Nathan Cutler about 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF