Project

General

Profile

Bug #2221

Monitor setup bugs

Added by Greg Farnum almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

100%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Carl reported several configuration issues when creating new monitors (based on the instructions at http://ceph.newdream.net/docs/master/ops/manage/grow/mon/#adding-a-monitor)
1) fsid passed in via command line is ignored if you pass a monmap
2) if you don't pass a monmap the config file is ignored
3) if you specify monitors using -m the first IP has to be your local IP or it will fail by using the wrong names
4) there's no way to specify fsid when creating a monmap

I haven't yet looked into this enough to know if they're bugs in the monitor creation code or the common config code, but they should be fixed!


Subtasks

Bug #2338: mon: adding new monitors simultaneously can allow a new mon to become leaderRejectedGreg Farnum

Bug #2363: mon: ./ceph-mon -i b --mkfs -c ceph.conf segfaultsResolvedGreg Farnum

Bug #2364: mon: can't specify monitor to join with -mWon't FixGreg Farnum

History

#1 Updated by Greg Farnum almost 9 years ago

  • Assignee set to Greg Farnum

#2 Updated by Greg Farnum almost 9 years ago

  • Status changed from New to 4

(1) is a problem due to options parsing collisions...fixed!
(2) is directly contradicted by my testing...?
(3) I need more details on.
(4) is actually incorrect. You can pass "--fsid uuid" to the monmaptool and it will make use of it. I added documentation to the help string, but it's already in the docs under the monmaptool section. (And by fixing (1) you can do it with ceph-mon --mkfs too!)

Talking to Carl about them.

#3 Updated by Greg Farnum almost 9 years ago

2)

When I did not have a monmap, but did have a ceph.conf, the mkfs would
work but the monitor would suicide right after startup when attempting
to connect to another monitor. I was assuming this was config file
parsing issue, but I could be wrong.

3)
When I tried to use the -m flag, whatever IP address passed in first
would be the address the monitor would attempt to bond to. Didn't
matter what was in the config file. Looks like the monmap always takes
precedence. The other monitors had bogus names in the monmap as well,
which concerned me that they would not work.

#4 Updated by Greg Farnum almost 9 years ago

  • Status changed from 4 to Resolved

I have spent way too long doing monitor additions lately, and I've gotten a few things cleaned up and checking the docs, and I think it's as good as we can reasonably make it right now. Any remaining issues will need to be dealt with by training.

Also available in: Atom PDF