Project

General

Profile

Bug #19116

Sporadic segfaults in lockdep_locked on startup

Added by Alexey Sheplyakov over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/01/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

/home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir/out/client.admin.18512.asok is too long! The maximum length on this system is 107
  • Caught signal (Segmentation fault)
    in thread 2aecb7e21700 thread_name:service
    ceph version 10.2.5-6118-g18ba7c9 (18ba7c9ef282ce0d71a34d287fb0654f103c3fd5)
    1: (()+0x10e6c2) [0x2aecab4676c2]
    2: (()+0x10330) [0x2aecb4eb2330]
    3: (std::__detail::_Map_base<unsigned long, std::pair<unsigned long const, std::map<int, ceph::BackTrace*, std::less<int>, std::allocator<std::pair<int const, ceph::BackTrace*> > > >, std::allocator<std::pair<unsigned long const, std::map<int, ceph::BackTrace*, std::less<int>, std::allocator<std::pair<int const, ceph::BackTrace*> > > > >, std::__detail::_Select1st, std::equal_to<unsigned long>, std::hash<unsigned long>, std::__detail::_Mod_range_hashing, std::__detail::_Default_ranged_hash, std::__detail::_Prime_rehash_policy, std::__detail::_Hashtable_traits<false, false, true>, true>::operator[](unsigned long const&)+0x2c) [0x2aecab528a2c]
    4: (lockdep_locked(char const*, int, bool)+0xa8) [0x2aecab5273d8]
    5: (Mutex::Lock(bool)+0x9c) [0x2aecab48d6bc]
    6: (CephContextServiceThread::entry()+0x169) [0x2aecab4c92b9]
    7: (()+0x8184) [0x2aecb4eaa184]
    8: (clone()+0x6d) [0x2aecb657937d]
    2017-03-01 07:39:57.382206 2aecb7e21700 -1
    Caught signal (Segmentation fault) *
    in thread 2aecb7e21700 thread_name:service
ceph version 10.2.5-6118-g18ba7c9 (18ba7c9ef282ce0d71a34d287fb0654f103c3fd5)
1: (()+0x10e6c2) [0x2aecab4676c2]
2: (()+0x10330) [0x2aecb4eb2330]
3: (std::__detail::_Map_base&lt;unsigned long, std::pair&lt;unsigned long const, std::map&lt;int, ceph::BackTrace*, std::less&lt;int&gt;, std::allocator&lt;std::pair&lt;int const, ceph::BackTrace*&gt; > > >, std::allocator&lt;std::pair&lt;unsigned long const, std::map&lt;int, ceph::BackTrace*, std::less&lt;int&gt;, std::allocator&lt;std::pair&lt;int const, ceph::BackTrace*&gt; > > > >, std::__detail::_Select1st, std::equal_to&lt;unsigned long&gt;, std::hash&lt;unsigned long&gt;, std::__detail::_Mod_range_hashing, std::__detail::_Default_ranged_hash, std::__detail::_Prime_rehash_policy, std::__detail::_Hashtable_traits&lt;false, false, true&gt;, true>::operator[](unsigned long const&)+0x2c) [0x2aecab528a2c]
4: (lockdep_locked(char const*, int, bool)+0xa8) [0x2aecab5273d8]
5: (Mutex::Lock(bool)+0x9c) [0x2aecab48d6bc]
6: (CephContextServiceThread::entry()+0x169) [0x2aecab4c92b9]
7: (()+0x8184) [0x2aecb4eaa184]
8: (clone()+0x6d) [0x2aecb657937d]
NOTE: a copy of the executable, or `objdump -rdS &lt;executable&gt;` is needed to interpret this.

--- begin dump of recent events ---
-21> 2017-03-01 07:39:57.332130 2aecab663fc0 5 asok(0x2aecab668580) register_command perfcounters_dump hook 0x2aecab66b6d0
-20> 2017-03-01 07:39:57.332148 2aecab663fc0 5 asok(0x2aecab668580) register_command 1 hook 0x2aecab66b6d0
-19> 2017-03-01 07:39:57.332160 2aecab663fc0 5 asok(0x2aecab668580) register_command perf dump hook 0x2aecab66b6d0
-18> 2017-03-01 07:39:57.332162 2aecab663fc0 5 asok(0x2aecab668580) register_command perfcounters_schema hook 0x2aecab66b6d0
-17> 2017-03-01 07:39:57.332164 2aecab663fc0 5 asok(0x2aecab668580) register_command 2 hook 0x2aecab66b6d0
-16> 2017-03-01 07:39:57.332166 2aecab663fc0 5 asok(0x2aecab668580) register_command perf schema hook 0x2aecab66b6d0
-15> 2017-03-01 07:39:57.332170 2aecab663fc0 5 asok(0x2aecab668580) register_command perf reset hook 0x2aecab66b6d0
-14> 2017-03-01 07:39:57.332172 2aecab663fc0 5 asok(0x2aecab668580) register_command config show hook 0x2aecab66b6d0
-13> 2017-03-01 07:39:57.332174 2aecab663fc0 5 asok(0x2aecab668580) register_command config set hook 0x2aecab66b6d0
-12> 2017-03-01 07:39:57.332175 2aecab663fc0 5 asok(0x2aecab668580) register_command config get hook 0x2aecab66b6d0
-11> 2017-03-01 07:39:57.332177 2aecab663fc0 5 asok(0x2aecab668580) register_command config diff hook 0x2aecab66b6d0
-10> 2017-03-01 07:39:57.332178 2aecab663fc0 5 asok(0x2aecab668580) register_command log flush hook 0x2aecab66b6d0
-9> 2017-03-01 07:39:57.332182 2aecab663fc0 5 asok(0x2aecab668580) register_command log dump hook 0x2aecab66b6d0
-8> 2017-03-01 07:39:57.332184 2aecab663fc0 5 asok(0x2aecab668580) register_command log reopen hook 0x2aecab66b6d0
-7> 2017-03-01 07:39:57.336645 2aecab663fc0 0 lockdep start
-6> 2017-03-01 07:39:57.336847 2aecab663fc0 -1 WARNING: the following dangerous and experimental features are enabled:
-5> 2017-03-01 07:39:57.336890 2aecab663fc0 -1 WARNING: the following dangerous and experimental features are enabled: *
-4> 2017-03-01 07:39:57.338387 2aecab663fc0 -1 WARNING: the following dangerous and experimental features are enabled: *
-3> 2017-03-01 07:39:57.338392 2aecab663fc0 5 asok(0x2aecab668580) init /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir/out/client.admin.18512.asok
-2> 2017-03-01 07:39:57.338403 2aecab663fc0 5 asok(0x2aecab668580) bind_and_listen /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir/out/client.admin.18512.asok
-1> 2017-03-01 07:39:57.338406 2aecab663fc0 -1 asok(0x2aecab668580) AdminSocketConfigObs::init: failed: AdminSocket::bind_and_listen: The UNIX domain socket path /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir/out/client.admin.18512.asok is too long! The maximum length on this system is 107
0> 2017-03-01 07:39:57.382206 2aecb7e21700 -1 *
* Caught signal (Segmentation fault) **
in thread 2aecb7e21700 thread_name:service

ceph version 10.2.5-6118-g18ba7c9 (18ba7c9ef282ce0d71a34d287fb0654f103c3fd5)
1: (()+0x10e6c2) [0x2aecab4676c2]
2: (()+0x10330) [0x2aecb4eb2330]
3: (std::__detail::_Map_base&lt;unsigned long, std::pair&lt;unsigned long const, std::map&lt;int, ceph::BackTrace*, std::less&lt;int&gt;, std::allocator&lt;std::pair&lt;int const, ceph::BackTrace*&gt; > > >, std::allocator&lt;std::pair&lt;unsigned long const, std::map&lt;int, ceph::BackTrace*, std::less&lt;int&gt;, std::allocator&lt;std::pair&lt;int const, ceph::BackTrace*&gt; > > > >, std::__detail::_Select1st, std::equal_to&lt;unsigned long&gt;, std::hash&lt;unsigned long&gt;, std::__detail::_Mod_range_hashing, std::__detail::_Default_ranged_hash, std::__detail::_Prime_rehash_policy, std::__detail::_Hashtable_traits&lt;false, false, true&gt;, true>::operator[](unsigned long const&)+0x2c) [0x2aecab528a2c]
4: (lockdep_locked(char const*, int, bool)+0xa8) [0x2aecab5273d8]
5: (Mutex::Lock(bool)+0x9c) [0x2aecab48d6bc]
6: (CephContextServiceThread::entry()+0x169) [0x2aecab4c92b9]
7: (()+0x8184) [0x2aecb4eaa184]
8: (clone()+0x6d) [0x2aecb657937d]
NOTE: a copy of the executable, or `objdump -rdS &lt;executable&gt;` is needed to interpret this.

--- logging levels ---
0/ 5 none
0/ 1 lockdep
0/ 1 context
1/ 1 crush
1/ 5 mds
1/ 5 mds_balancer
1/ 5 mds_locker
1/ 5 mds_log
1/ 5 mds_log_expire
1/ 5 mds_migrator
0/ 1 buffer
0/ 1 timer
0/ 1 filer
0/ 1 striper
0/ 1 objecter
0/ 5 rados
0/ 5 rbd
0/ 5 rbd_mirror
0/ 5 rbd_replay
0/ 5 journaler
0/ 5 objectcacher
0/ 5 client
0/ 5 osd
0/ 5 optracker
0/ 5 objclass
1/ 3 filestore
1/ 3 journal
0/ 5 ms
1/ 5 mon
0/10 monc
1/ 5 paxos
0/ 5 tp
1/ 5 auth
1/ 5 crypto
1/ 1 finisher
1/ 5 heartbeatmap
1/ 5 perfcounter
1/ 5 rgw
1/10 civetweb
1/ 5 javaclient
1/ 5 asok
1/ 1 throttle
0/ 0 refs
1/ 5 xio
1/ 5 compressor
1/ 5 newstore
1/ 5 bluestore
1/ 5 bluefs
1/ 3 bdev
1/ 5 kstore
4/ 5 rocksdb
4/ 5 leveldb
1/ 5 kinetic
1/ 5 fuse
2/-2 (syslog threshold)
99/99 (stderr threshold)
max_recent 500
max_new 1000
log_file /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir/out/client.admin.18512.log
--
end dump of recent events ---

https://jenkins.ceph.com/job/ceph-pull-requests/19344/consoleText


Related issues

Duplicates Ceph - Bug #16014: test fails due to "The UNIX domain socket path" Resolved 05/25/2016

History

#1 Updated by Greg Farnum over 2 years ago

  • Duplicates Bug #16014: test fails due to "The UNIX domain socket path" added

#2 Updated by Greg Farnum over 2 years ago

  • Status changed from New to Duplicate

I think this is just a jewel dup of 16014

Also available in: Atom PDF