Project

General

Profile

Bug #17106

SUSE builds do not create __pycache__ files

Added by Nathan Cutler about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
08/23/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Credits to Tim Serong for finding this bug.

https://github.com/ceph/ceph/commit/73042684 added packages for Python 3 bindings, including packaging some files in __pycache__ directories. This is in accordance with Fedora packaging guidelines [1].

I assume these __pycache__ directories and the files they contain are created only when the build machine is connected to the network. (That's the most obvious explanation for why they are not created in OBS builds.)

Since these directories/files will be created automatically if they are missing, they can be safely omitted in SUSE builds - at least for now.

[1]
https://fedoraproject.org/wiki/Packaging:Python
"When packaging python modules, several types of files are included:
*.pyc and *.pyo byte compiled files (and, if present, the enclosing __pycache__ directory in most cases)."

History

#1 Updated by Nathan Cutler about 3 years ago

  • Description updated (diff)

#2 Updated by Nathan Cutler about 3 years ago

  • Description updated (diff)

#3 Updated by Nathan Cutler about 3 years ago

  • Source changed from other to Community (dev)

#4 Updated by Tim Serong about 3 years ago

Ah, that means https://github.com/ceph/ceph/pull/10805 will probably need an "%if ! 0%{?suse_version}" guard...

#5 Updated by Nathan Cutler about 3 years ago

  • Status changed from New to In Progress

https://github.com/ceph/ceph/pull/10805 was merged, but in the meantime dimstar77 suggested a way to force creation of the __pycache__ in the spec file.

#6 Updated by Nathan Cutler about 3 years ago

  • Status changed from In Progress to Testing

#7 Updated by Nathan Cutler about 3 years ago

  • Status changed from Testing to Resolved

Also available in: Atom PDF