Project

General

Profile

Bug #16444

rgw-admin: better error message when user has no buckets yet

Added by Abhishek Lekshmanan about 4 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When user hasn't created any buckets, user stats will return


$ radosgw-admin user  stats --uid=testid  

ERROR: can't read user header: (2) No such file or directory

This is because we still haven't created a userid.buckets object yet, we can improvise the error message for the user though

History

#1 Updated by Gaurav Garg about 4 years ago

I am working on this bug.

#2 Updated by Gaurav Garg about 4 years ago

I am working on this bug. I don't have bug assignee permission to myself yet.

#4 Updated by Nathan Cutler about 4 years ago

  • Status changed from New to Fix Under Review

#5 Updated by Gaurav Garg almost 4 years ago

#6 Updated by Daniel Gryniewicz 4 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF