Project

General

Profile

Bug #15566

[centos] jewel el7 repos corrupted

Added by Vasu Kulkarni almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
build
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

This was reported in irc, after trying the flag release=jewel on centos it actually fails with below error

http://qa-proxy.ceph.com/teuthology/vasu-2016-04-21_17:57:25-ceph-deploy-jewel---basic-vps/143110/teuthology.log

2016-04-21T18:18:04.919 INFO:teuthology.orchestra.run.vpm081:Running: 'sudo chmod 664 /home/ubuntu/cephtest/ceph-deploy/ceph.conf'
2016-04-21T18:18:05.030 INFO:teuthology.orchestra.run.vpm081:Running: 'cd /home/ubuntu/cephtest/ceph-deploy && ./ceph-deploy install --release=jewel vpm081 vpm095'
2016-04-21T18:18:05.252 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.conf][DEBUG ] found configuration file at: /home/ubuntu/.cephdeploy.conf
2016-04-21T18:18:05.252 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ] Invoked (1.5.32): ./ceph-deploy install --release=jewel vpm081 vpm095
2016-04-21T18:18:05.252 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ] ceph-deploy options:
2016-04-21T18:18:05.253 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  verbose                       : False
2016-04-21T18:18:05.253 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  testing                       : None
2016-04-21T18:18:05.253 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  cd_conf                       : <ceph_deploy.conf.cephdeploy.Conf instance at 0x295fb48>
2016-04-21T18:18:05.253 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  cluster                       : ceph
2016-04-21T18:18:05.254 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  dev_commit                    : None
2016-04-21T18:18:05.254 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_mds                   : False
2016-04-21T18:18:05.254 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  stable                        : None
2016-04-21T18:18:05.254 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  default_release               : False
2016-04-21T18:18:05.255 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  username                      : None
2016-04-21T18:18:05.255 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  adjust_repos                  : True
2016-04-21T18:18:05.255 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  func                          : <function install at 0x28e8d70>
2016-04-21T18:18:05.255 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_all                   : False
2016-04-21T18:18:05.256 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  repo                          : False
2016-04-21T18:18:05.256 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  host                          : ['vpm081', 'vpm095']
2016-04-21T18:18:05.256 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_rgw                   : False
2016-04-21T18:18:05.257 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_tests                 : False
2016-04-21T18:18:05.257 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  repo_url                      : None
2016-04-21T18:18:05.257 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  ceph_conf                     : None
2016-04-21T18:18:05.257 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_osd                   : False
2016-04-21T18:18:05.258 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  version_kind                  : stable
2016-04-21T18:18:05.258 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_common                : False
2016-04-21T18:18:05.258 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  overwrite_conf                : False
2016-04-21T18:18:05.258 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  quiet                         : False
2016-04-21T18:18:05.259 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  dev                           : master
2016-04-21T18:18:05.259 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  local_mirror                  : None
2016-04-21T18:18:05.259 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  release                       : jewel
2016-04-21T18:18:05.259 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  install_mon                   : False
2016-04-21T18:18:05.260 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.cli][INFO  ]  gpg_url                       : None
2016-04-21T18:18:05.260 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.install][DEBUG ] Installing stable version jewel on cluster ceph hosts vpm081 vpm095
2016-04-21T18:18:05.260 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.install][DEBUG ] Detecting platform for host vpm081 ...
2016-04-21T18:18:05.300 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] connection detected need for sudo
2016-04-21T18:18:05.327 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] connected to host: vpm081
2016-04-21T18:18:05.328 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] detect platform information from remote host
2016-04-21T18:18:05.351 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] detect machine type
2016-04-21T18:18:05.355 INFO:teuthology.orchestra.run.vpm081.stderr:[ceph_deploy.install][INFO  ] Distro info: CentOS Linux 7.2.1511 Core
2016-04-21T18:18:05.355 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] installing Ceph on vpm081
2016-04-21T18:18:05.365 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo yum clean all
2016-04-21T18:18:05.566 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loaded plugins: fastestmirror, langpacks, priorities
2016-04-21T18:18:05.566 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Cleaning repos: base centos7-fcgi-ceph epel extras lab-extras updates
2016-04-21T18:18:05.567 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Cleaning up everything
2016-04-21T18:18:05.589 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Cleaning up list of fastest mirrors
2016-04-21T18:18:05.600 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo yum -y install epel-release
2016-04-21T18:18:05.795 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loaded plugins: fastestmirror, langpacks, priorities
2016-04-21T18:18:08.872 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Determining fastest mirrors
2016-04-21T18:18:09.194 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * base: mirror.rackspace.com
2016-04-21T18:18:09.195 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * epel: ftp.linux.ncsu.edu
2016-04-21T18:18:09.195 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * extras: mirrors.lga7.us.voxel.net
2016-04-21T18:18:09.195 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * updates: mirror.vcu.edu
2016-04-21T18:18:13.292 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Resolving Dependencies
2016-04-21T18:18:13.293 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Running transaction check
2016-04-21T18:18:13.293 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package epel-release.noarch 0:7-6 will be installed
2016-04-21T18:18:14.368 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Finished Dependency Resolution
2016-04-21T18:18:14.581 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:14.581 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Dependencies Resolved
2016-04-21T18:18:14.581 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:14.582 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:14.582 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  Package                 Arch              Version        Repository       Size
2016-04-21T18:18:14.582 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:14.583 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Installing:
2016-04-21T18:18:14.583 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  epel-release            noarch            7-6            epel             14 k
2016-04-21T18:18:14.583 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:14.583 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Transaction Summary
2016-04-21T18:18:14.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:14.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Install  1 Package
2016-04-21T18:18:14.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:14.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Total download size: 14 k
2016-04-21T18:18:14.585 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Installed size: 24 k
2016-04-21T18:18:14.585 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Downloading packages:
2016-04-21T18:18:14.870 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Running transaction check
2016-04-21T18:18:14.870 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Running transaction test
2016-04-21T18:18:14.871 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Transaction test succeeded
2016-04-21T18:18:14.871 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Running transaction
2016-04-21T18:18:14.940 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]   Installing : epel-release-7-6.noarch                                      1/1
2016-04-21T18:18:14.940 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] warning: /etc/yum.repos.d/epel-testing.repo created as /etc/yum.repos.d/epel-testing.repo.rpmnew
2016-04-21T18:18:14.941 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] warning: /etc/yum.repos.d/epel.repo created as /etc/yum.repos.d/epel.repo.rpmnew
2016-04-21T18:18:15.123 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]   Verifying  : epel-release-7-6.noarch                                      1/1
2016-04-21T18:18:15.123 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:15.123 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Installed:
2016-04-21T18:18:15.123 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]   epel-release.noarch 0:7-6
2016-04-21T18:18:15.124 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:15.124 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Complete!
2016-04-21T18:18:15.263 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo yum -y install yum-plugin-priorities
2016-04-21T18:18:15.463 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loaded plugins: fastestmirror, langpacks, priorities
2016-04-21T18:18:15.485 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loading mirror speeds from cached hostfile
2016-04-21T18:18:15.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * base: mirror.rackspace.com
2016-04-21T18:18:15.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * epel: ftp.linux.ncsu.edu
2016-04-21T18:18:15.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * extras: mirrors.lga7.us.voxel.net
2016-04-21T18:18:15.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * updates: mirror.vcu.edu
2016-04-21T18:18:17.086 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Package yum-plugin-priorities-1.1.31-34.el7.noarch already installed and latest version
2016-04-21T18:18:17.086 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Nothing to do
2016-04-21T18:18:17.184 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Configure Yum priorities to include obsoletes
2016-04-21T18:18:17.186 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] check_obsoletes has been enabled for Yum priorities plugin
2016-04-21T18:18:17.192 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo rpm --import https://download.ceph.com/keys/release.asc
2016-04-21T18:18:17.640 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo rpm -Uvh --replacepkgs https://download.ceph.com/rpm-jewel/el7/noarch/ceph-release-1-0.el7.noarch.rpm
2016-04-21T18:18:17.886 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Retrieving https://download.ceph.com/rpm-jewel/el7/noarch/ceph-release-1-0.el7.noarch.rpm
2016-04-21T18:18:17.886 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Preparing...                          ########################################
2016-04-21T18:18:17.887 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Updating / installing...
2016-04-21T18:18:17.887 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ceph-release-1-1.el7                  ########################################
2016-04-21T18:18:17.887 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] ensuring that /etc/yum.repos.d/ceph.repo contains a high priority
2016-04-21T18:18:17.888 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] altered ceph.repo priorities to contain: priority=1
2016-04-21T18:18:17.895 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][INFO  ] Running command: sudo yum -y install ceph ceph-radosgw
2016-04-21T18:18:18.089 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loaded plugins: fastestmirror, langpacks, priorities
2016-04-21T18:18:18.473 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Loading mirror speeds from cached hostfile
2016-04-21T18:18:18.473 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * base: mirror.rackspace.com
2016-04-21T18:18:18.473 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * epel: ftp.linux.ncsu.edu
2016-04-21T18:18:18.473 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * extras: mirrors.lga7.us.voxel.net
2016-04-21T18:18:18.474 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  * updates: mirror.vcu.edu
2016-04-21T18:18:20.410 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] 25 packages excluded due to repository priority protections
2016-04-21T18:18:21.328 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Resolving Dependencies
2016-04-21T18:18:21.329 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Running transaction check
2016-04-21T18:18:21.329 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.329 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-mds = 1:10.2.0-0.el7 for package: 1:ceph-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.361 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-osd = 1:10.2.0-0.el7 for package: 1:ceph-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.361 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-mon = 1:10.2.0-0.el7 for package: 1:ceph-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.372 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-radosgw.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.383 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-selinux = 1:10.2.0-0.el7 for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.383 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: librados2 = 1:10.2.0-0.el7 for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.384 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-common = 1:10.2.0-0.el7 for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.395 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: librgw2 = 1:10.2.0-0.el7 for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.395 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-flask for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.396 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: librgw.so.2()(64bit) for package: 1:ceph-radosgw-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.396 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Running transaction check
2016-04-21T18:18:21.396 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-common.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.462 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-cephfs = 1:10.2.0-0.el7 for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.462 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-rbd = 1:10.2.0-0.el7 for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.473 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-rados = 1:10.2.0-0.el7 for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.474 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: librbd1 = 1:10.2.0-0.el7 for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.474 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libcephfs1 = 1:10.2.0-0.el7 for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.474 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-requests for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.475 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libboost_program_options-mt.so.1.53.0()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.485 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libradosstriper.so.1()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libbabeltrace-ctf.so.1()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libboost_regex-mt.so.1.53.0()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.486 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libboost_iostreams-mt.so.1.53.0()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.496 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libbabeltrace.so.1()(64bit) for package: 1:ceph-common-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.496 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-mds.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.507 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: ceph-base = 1:10.2.0-0.el7 for package: 1:ceph-mds-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.518 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-mon.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.529 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libboost_random-mt.so.1.53.0()(64bit) for package: 1:ceph-mon-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.541 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: libleveldb.so.1()(64bit) for package: 1:ceph-mon-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.541 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-osd.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.562 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-selinux.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.573 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: selinux-policy-base >= 3.13.1-60.el7_2.3 for package: 1:ceph-selinux-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package librados2.x86_64 1:0.80.7-3.el7 will be updated
2016-04-21T18:18:21.584 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package librados2.x86_64 1:10.2.0-0.el7 will be an update
2016-04-21T18:18:21.606 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: liblttng-ust.so.0()(64bit) for package: 1:librados2-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.606 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package librgw2.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.628 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-flask.noarch 1:0.10.1-4.el7 will be installed
2016-04-21T18:18:21.639 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-werkzeug for package: 1:python-flask-0.10.1-4.el7.noarch
2016-04-21T18:18:21.640 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-jinja2 for package: 1:python-flask-0.10.1-4.el7.noarch
2016-04-21T18:18:21.640 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-itsdangerous for package: 1:python-flask-0.10.1-4.el7.noarch
2016-04-21T18:18:21.640 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Running transaction check
2016-04-21T18:18:21.640 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package boost-iostreams.x86_64 0:1.53.0-25.el7 will be installed
2016-04-21T18:18:21.650 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package boost-program-options.x86_64 0:1.53.0-25.el7 will be installed
2016-04-21T18:18:21.661 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package boost-random.x86_64 0:1.53.0-25.el7 will be installed
2016-04-21T18:18:21.661 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package boost-regex.x86_64 0:1.53.0-25.el7 will be installed
2016-04-21T18:18:21.671 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package ceph-base.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.716 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: hdparm for package: 1:ceph-base-10.2.0-0.el7.x86_64
2016-04-21T18:18:21.716 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package leveldb.x86_64 0:1.12.0-5.el7 will be installed
2016-04-21T18:18:21.716 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package libbabeltrace.x86_64 0:1.2.4-3.el7 will be installed
2016-04-21T18:18:21.726 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package libcephfs1.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.749 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package libradosstriper1.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.760 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package librbd1.x86_64 1:0.80.7-3.el7 will be updated
2016-04-21T18:18:21.760 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package librbd1.x86_64 1:10.2.0-0.el7 will be an update
2016-04-21T18:18:21.783 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package lttng-ust.x86_64 0:2.4.1-1.el7 will be installed
2016-04-21T18:18:21.795 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: liburcu-cds.so.1()(64bit) for package: lttng-ust-2.4.1-1.el7.x86_64
2016-04-21T18:18:21.795 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: liburcu-bp.so.1()(64bit) for package: lttng-ust-2.4.1-1.el7.x86_64
2016-04-21T18:18:21.795 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-cephfs.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.807 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-itsdangerous.noarch 0:0.23-2.el7 will be installed
2016-04-21T18:18:21.807 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-jinja2.noarch 0:2.7.2-2.el7 will be installed
2016-04-21T18:18:21.807 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-babel >= 0.8 for package: python-jinja2-2.7.2-2.el7.noarch
2016-04-21T18:18:21.807 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-markupsafe for package: python-jinja2-2.7.2-2.el7.noarch
2016-04-21T18:18:21.808 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-rados.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.808 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-rbd.x86_64 1:10.2.0-0.el7 will be installed
2016-04-21T18:18:21.818 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-requests.noarch 0:2.6.0-1.el7_1 will be installed
2016-04-21T18:18:21.818 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-1.el7_1.noarch
2016-04-21T18:18:21.819 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-werkzeug.noarch 0:0.9.1-2.el7 will be installed
2016-04-21T18:18:21.819 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package selinux-policy-targeted.noarch 0:3.13.1-60.el7 will be updated
2016-04-21T18:18:21.819 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package selinux-policy-targeted.noarch 0:3.13.1-60.el7_2.3 will be an update
2016-04-21T18:18:21.830 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: selinux-policy = 3.13.1-60.el7_2.3 for package: selinux-policy-targeted-3.13.1-60.el7_2.3.noarch
2016-04-21T18:18:21.831 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Processing Dependency: selinux-policy = 3.13.1-60.el7_2.3 for package: selinux-policy-targeted-3.13.1-60.el7_2.3.noarch
2016-04-21T18:18:21.831 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Running transaction check
2016-04-21T18:18:21.831 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package hdparm.x86_64 0:9.43-5.el7 will be installed
2016-04-21T18:18:21.831 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-babel.noarch 0:0.9.6-8.el7 will be installed
2016-04-21T18:18:21.832 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-markupsafe.x86_64 0:0.11-10.el7 will be installed
2016-04-21T18:18:21.842 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package python-urllib3.noarch 0:1.10.2-2.el7_1 will be installed
2016-04-21T18:18:21.842 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package selinux-policy.noarch 0:3.13.1-60.el7 will be updated
2016-04-21T18:18:21.843 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package selinux-policy.noarch 0:3.13.1-60.el7_2.3 will be an update
2016-04-21T18:18:21.853 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ---> Package userspace-rcu.x86_64 0:0.7.16-1.el7 will be installed
2016-04-21T18:18:22.741 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] --> Finished Dependency Resolution
2016-04-21T18:18:22.909 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:22.910 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Dependencies Resolved
2016-04-21T18:18:22.916 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:22.916 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:22.917 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  Package                     Arch       Version               Repository   Size
2016-04-21T18:18:22.917 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:22.917 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Installing:
2016-04-21T18:18:22.918 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph                        x86_64     1:10.2.0-0.el7        Ceph        2.0 k
2016-04-21T18:18:22.918 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-radosgw                x86_64     1:10.2.0-0.el7        Ceph        245 k
2016-04-21T18:18:22.918 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Installing for dependencies:
2016-04-21T18:18:22.918 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  boost-iostreams             x86_64     1.53.0-25.el7         base         60 k
2016-04-21T18:18:22.918 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  boost-program-options       x86_64     1.53.0-25.el7         base        155 k
2016-04-21T18:18:22.919 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  boost-random                x86_64     1.53.0-25.el7         base         38 k
2016-04-21T18:18:22.919 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  boost-regex                 x86_64     1.53.0-25.el7         base        294 k
2016-04-21T18:18:22.919 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-base                   x86_64     1:10.2.0-0.el7        Ceph        4.2 M
2016-04-21T18:18:22.919 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-common                 x86_64     1:10.2.0-0.el7        Ceph         15 M
2016-04-21T18:18:22.920 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-mds                    x86_64     1:10.2.0-0.el7        Ceph        2.8 M
2016-04-21T18:18:22.920 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-mon                    x86_64     1:10.2.0-0.el7        Ceph        2.8 M
2016-04-21T18:18:22.920 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-osd                    x86_64     1:10.2.0-0.el7        Ceph        9.0 M
2016-04-21T18:18:22.920 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  ceph-selinux                x86_64     1:10.2.0-0.el7        Ceph         19 k
2016-04-21T18:18:22.920 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  hdparm                      x86_64     9.43-5.el7            base         83 k
2016-04-21T18:18:22.921 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  leveldb                     x86_64     1.12.0-5.el7          epel        158 k
2016-04-21T18:18:22.921 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  libbabeltrace               x86_64     1.2.4-3.el7           epel        147 k
2016-04-21T18:18:22.921 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  libcephfs1                  x86_64     1:10.2.0-0.el7        Ceph        1.8 M
2016-04-21T18:18:22.921 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  libradosstriper1            x86_64     1:10.2.0-0.el7        Ceph        1.8 M
2016-04-21T18:18:22.921 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  librgw2                     x86_64     1:10.2.0-0.el7        Ceph        2.8 M
2016-04-21T18:18:22.922 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  lttng-ust                   x86_64     2.4.1-1.el7           epel        176 k
2016-04-21T18:18:22.922 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-babel                noarch     0.9.6-8.el7           base        1.4 M
2016-04-21T18:18:22.922 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-cephfs               x86_64     1:10.2.0-0.el7        Ceph         66 k
2016-04-21T18:18:22.922 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-flask                noarch     1:0.10.1-4.el7        extras      204 k
2016-04-21T18:18:22.922 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-itsdangerous         noarch     0.23-2.el7            extras       24 k
2016-04-21T18:18:22.923 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-jinja2               noarch     2.7.2-2.el7           base        515 k
2016-04-21T18:18:22.923 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-markupsafe           x86_64     0.11-10.el7           base         25 k
2016-04-21T18:18:22.923 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-rados                x86_64     1:10.2.0-0.el7        Ceph        145 k
2016-04-21T18:18:22.923 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-rbd                  x86_64     1:10.2.0-0.el7        Ceph         61 k
2016-04-21T18:18:22.924 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-requests             noarch     2.6.0-1.el7_1         base         94 k
2016-04-21T18:18:22.924 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-urllib3              noarch     1.10.2-2.el7_1        base        100 k
2016-04-21T18:18:22.924 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  python-werkzeug             noarch     0.9.1-2.el7           extras      562 k
2016-04-21T18:18:22.924 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  userspace-rcu               x86_64     0.7.16-1.el7          epel         73 k
2016-04-21T18:18:22.924 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Updating for dependencies:
2016-04-21T18:18:22.925 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  librados2                   x86_64     1:10.2.0-0.el7        Ceph        1.9 M
2016-04-21T18:18:22.925 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  librbd1                     x86_64     1:10.2.0-0.el7        Ceph        2.4 M
2016-04-21T18:18:22.925 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  selinux-policy              noarch     3.13.1-60.el7_2.3     updates     375 k
2016-04-21T18:18:22.925 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]  selinux-policy-targeted     noarch     3.13.1-60.el7_2.3     updates     3.9 M
2016-04-21T18:18:22.925 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Transaction Summary
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] ================================================================================
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Install  2 Packages (+29 Dependent packages)
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Upgrade             (  4 Dependent packages)
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ]
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Total download size: 53 M
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Downloading packages:
2016-04-21T18:18:22.926 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][DEBUG ] Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
2016-04-21T18:18:23.320 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-10.2.0-0.el7.x86_64.rpm: [Errno 14] curl#63 - "Callback aborted" 
2016-04-21T18:18:23.321 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:23.490 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-base-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:23.490 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:23.759 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-common-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:23.760 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:23.827 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-mds-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:23.828 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:23.897 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-mon-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:23.897 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.074 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-osd-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.075 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.075 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-radosgw-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.076 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.133 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-selinux-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.133 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.196 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/libcephfs1-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.197 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.242 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/librados2-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.243 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.310 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/libradosstriper1-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.310 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.346 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/librbd1-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.347 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.411 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/librgw2-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.411 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.793 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/python-cephfs-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.793 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.995 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/python-rados-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata
2016-04-21T18:18:24.995 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] Trying other mirror.
2016-04-21T18:18:24.995 INFO:teuthology.orchestra.run.vpm081.stderr:[vpm081][WARNING] http://download.ceph.com/rpm-jewel/el7/x86_64/python-rbd-10.2.0-0.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=Ceph clean metadata

History

#1 Updated by Dan Mick almost 5 years ago

With much less wasted space:

[ceph]
name=Ceph packages for $basearch
baseurl=http://download.ceph.com/rpm-jewel/el7/$basearch
enabled=1
priority=2
gpgcheck=1
type=rpm-md
gpgkey=https://download.ceph.com/keys/release.asc

yum install ceph-deploy shows:

Downloading packages:
ceph-deploy-1.5.32-0.noarch.rp FAILED
http://download.ceph.com/rpm-jewel/el7/noarch/ceph-deploy-1.5.32-0.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=ceph-noarch clean metadata

I'm guessing that means repodata.xml doesn't match the actual rpms in checksum or something. verifytree from yum-utils (which I installed on download.ceph.com) shows the rpm checksums are wrong:

verifying 1:ceph-10.1.0-0.el7.x86_64 checksum FAILED
verifying 1:ceph-10.1.1-0.el7.x86_64 checksum FAILED
.
etc.

#2 Updated by Dan Mick almost 5 years ago

  • Project changed from Ceph-deploy to Ceph
  • Subject changed from [centos] with release=jewel http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-10.2.0-0.el7.x86_64.rpm: [Errno 14] curl#63 - "Callback aborted" to [centos] jewel el7 repos corrupted
  • Category set to build
  • Assignee set to Alfredo Deza
  • Priority changed from High to Urgent
  • Target version set to v10.2.0
  • Source changed from other to Community (user)

Discovered by ibravo in #ceph-devel

#3 Updated by Dan Mick almost 5 years ago

I tried rerunning createrepo; that made verifytree happy, and also (after yum clean all) made my install of ceph-deploy happy. I'm assuming we just failed to rerun createrepo after signing the packages.

#4 Updated by Dan Mick almost 5 years ago

  • Status changed from New to Fix Under Review

#5 Updated by Alfredo Deza almost 5 years ago

That is odd, we do run createrepo after signing. I will double check the process. I need to get some sanity checks before calling the release done. This is not the first time.

#6 Updated by Dan Mick almost 5 years ago

FWIW, the checksums were invalid in both the noarch and x86_64 repos.

#7 Updated by Vasu Kulkarni over 4 years ago

  • Status changed from Fix Under Review to 12

This has already been fixed, Marking verified.

#8 Updated by Kefu Chai over 4 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF