Project

General

Profile

Bug #15334

Multipart ListPartsResult has missing quotes on ETag

Added by Robin Johnson over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Sage: you reverted the new test_multipart_upload_missing_part and test_multipart_upload_incorrect_etag tests, but they were actually correct, and telling us that there is a regression in RGW, when compared to AWS-S3.
https://github.com/ceph/s3-tests/commit/7731afb5a04244a17054ed49fe7639d304c68768

What is more concerning, is that we've never had coverage on the exact content inside a ListPartsResult result, and the bug is present at least as far back as Hammer, that lack of coverage also caused issue #11494.

RGW response (Jewel, v10.1.0-152-g1cbe2bd)

<?xml version="1.0" encoding="UTF-8"?>
<ListPartsResult xmlns="http://s3.amazonaws.com/doc/2006-03-01/">
  <Bucket>robbat2mhxonsij9rofzl7tst67v7-1</Bucket>
  <Key>mymultipart</Key>
  <UploadId>2~ogoQK8QBVnS77-C1y_tjYyuc7U0UEmI</UploadId>
  <StorageClass>STANDARD</StorageClass>
  <PartNumberMarker>0</PartNumberMarker>
  <NextPartNumberMarker>1</NextPartNumberMarker>
  <MaxParts>1000</MaxParts>
  <IsTruncated>false</IsTruncated>
  <Owner>
    <ID>test1</ID>
    <DisplayName>test1</DisplayName>
  </Owner>
  <Part>
    <LastModified>2016-03-31T05:56:12.804Z</LastModified>
    <PartNumber>1</PartNumber>
    <ETag>93b885adfe0da089cdf634904fd59f71</ETag>
    <Size>1</Size>
  </Part>
</ListPartsResult>

AWS response:

<?xml version="1.0" encoding="UTF-8"?>
<ListPartsResult xmlns="http://s3.amazonaws.com/doc/2006-03-01/">
  <Bucket>robbat2-ceph-multipart-test</Bucket>
  <Key>56fcbc77-3616d8-s3-health-key-0001</Key>
  <UploadId>qrtBceWkgaw6Z5EDYxMY86my4tX0zswLxxRXmc700G_s5ZCmIWm_..JyypSxlKQC6pX0ECo_8oi0qrtClFRIGQqMX6K2boX1JhGEG7KQwio687UUYvy4P0vz_qQ1wrCQ</UploadId>
  <Initiator>
    <ID>X</ID>
    <DisplayName>X</DisplayName>
  </Initiator>
  <Owner>
    <ID>X</ID>
    <DisplayName>X</DisplayName>
  </Owner>
  <StorageClass>STANDARD</StorageClass>
  <PartNumberMarker>0</PartNumberMarker>
  <NextPartNumberMarker>2</NextPartNumberMarker>
  <MaxParts>1000</MaxParts>
  <IsTruncated>false</IsTruncated>
  <Part>
    <PartNumber>1</PartNumber>
    <LastModified>2016-03-31T05:58:19.000Z</LastModified>
    <ETag>"d01556f18fd2b20f2349eae8927f1636"</ETag>
    <Size>5242880</Size>
  </Part>
  <Part>
    <PartNumber>2</PartNumber>
    <LastModified>2016-03-31T05:58:17.000Z</LastModified>
    <ETag>"3a9273a4f8c5215daa5b46ab88a3ad48"</ETag>
    <Size>1048576</Size>
  </Part>
</ListPartsResult>


Related issues

Copied to rgw - Backport #15343: hammer: Multipart ListPartsResult has missing quotes on ETag Resolved

Associated revisions

Revision a58b774e (diff)
Added by Robin H. Johnson over 6 years ago

rgw: Multipart ListPartsResult ETag quotes

ListPartsResult output has always missed quotes on the ETag since it was
first committed.

Fixes: #15334
Backports: hammer, infernalis
Signed-off-by: Robin H. Johnson <>

Revision 2aa1ea6b (diff)
Added by Robin H. Johnson over 6 years ago

rgw: Multipart ListPartsResult ETag quotes

ListPartsResult output has always missed quotes on the ETag since it was
first committed.

Fixes: #15334
Backports: hammer, infernalis
Signed-off-by: Robin H. Johnson <>
(cherry picked from commit a58b774e72cc1613d62e10b25322d6d15e9d2899)

History

#2 Updated by Sage Weil over 6 years ago

  • Priority changed from Normal to Urgent

#3 Updated by Sage Weil over 6 years ago

  • Status changed from New to Resolved

#4 Updated by Nathan Cutler over 6 years ago

  • Status changed from Resolved to Pending Backport

#5 Updated by Nathan Cutler over 6 years ago

  • Copied to Backport #15343: hammer: Multipart ListPartsResult has missing quotes on ETag added

#6 Updated by Orit Wasserman over 6 years ago

the original fix caused a compilation error and requires https://github.com/ceph/ceph/pull/8394

#7 Updated by Yehuda Sadeh over 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF