Project

General

Profile

Bug #11494

rgw: multipart list part response returns incorrect field

Added by Yehuda Sadeh over 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Should return ListPartsResult, and not ListMultipartUploadResult


Related issues

Related to rgw - Documentation #14003: Incorrect name of the "List Multipart Upload Parts" Response Entities Resolved 12/07/2015
Copied to rgw - Backport #12399: rgw: multipart list part response returns incorrect field Resolved 04/28/2015

Associated revisions

Revision caa9f0e4 (diff)
Added by Henry Chang over 6 years ago

rgw: fix ListParts response

The response XML element name should be 'ListPartsResult'.

Fixes: #11494

Signed-off-by: Henry Chang <>

Revision 9458b845 (diff)
Added by Henry Chang about 6 years ago

rgw: fix ListParts response

The response XML element name should be 'ListPartsResult'.

Fixes: #11494

Signed-off-by: Henry Chang <>
(cherry picked from commit caa9f0e461f1eed526fc43ee74699a7243aef9b8)

History

#1 Updated by Lenz Grimmer about 6 years ago

Good timing, I was just about to report this :)

We use multi-part uploads in our application and stumbled over this one, too. For now, our code has now been changed to handle both return parameters, but it would of course be appropriate to use the "official" response (see http://docs.aws.amazon.com/AmazonS3/latest/API/mpUploadListParts.html).

By the way, while looking at the Ceph API docs at http://ceph.com/docs/master/radosgw/s3/objectops/#list-multipart-upload-parts, it claims that it returns "InitiatedMultipartUploadsResult", but that seems to be a documentation bug?

#2 Updated by Lenz Grimmer about 6 years ago

#3 Updated by Yehuda Sadeh about 6 years ago

  • Status changed from New to Pending Backport
  • Regression set to No

#5 Updated by Nathan Cutler almost 6 years ago

  • Status changed from Pending Backport to Resolved

#6 Updated by Lenz Grimmer over 5 years ago

FYI, I filed bug #14003 for the documentation update.

#7 Updated by Nathan Cutler over 5 years ago

  • Related to Documentation #14003: Incorrect name of the "List Multipart Upload Parts" Response Entities added

Also available in: Atom PDF