Project

General

Profile

Bug #1297

write a manypools teuthology task

Added by Anonymous about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
Start date:
07/11/2011
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Write a teuthology task that creates lots of pools:

tasks:
- manypools:
    num_of_pools: NUM
- radosbench:

The task would create NUM pools, each with a single dummy object (to enforce pools to exist on PGs). Then the yaml can run radosbench as the next task.

History

#1 Updated by Anonymous about 8 years ago

Nevermind the "track_memory_use" part, that can be done with collectd, and collectd buys us much much more.

#2 Updated by Sage Weil about 8 years ago

  • Category set to OSD
  • Target version set to v0.33

#3 Updated by Sage Weil about 8 years ago

  • translation missing: en.field_position set to 23

#4 Updated by Sage Weil about 8 years ago

  • translation missing: en.field_position deleted (27)
  • translation missing: en.field_position set to 15

#5 Updated by Greg Farnum about 8 years ago

  • Assignee set to Greg Farnum

#6 Updated by Greg Farnum about 8 years ago

  • Status changed from New to Testing

Running final tests now, but this appears to be working properly. Which is odd since it seemed broken before, but maybe I misread the information I was getting. Trying it on a 10k pool create now, anyway, so that ought to turn up any issues.

#7 Updated by Greg Farnum about 8 years ago

Ah, nope, it hung again. Without debugging enabled, naturally...

#8 Updated by Sage Weil about 8 years ago

  • Target version changed from v0.33 to v0.34

#9 Updated by Sage Weil about 8 years ago

  • translation missing: en.field_story_points set to 3
  • translation missing: en.field_position deleted (44)
  • translation missing: en.field_position set to 43

#10 Updated by Greg Farnum about 8 years ago

  • Subject changed from qa: find out max pools per osd (without running out of RAM, without degrading performance) to write a manypools teuthology task
  • Status changed from Testing to Resolved

So each pool is actually 8 PGs each by default, so the task just writes 16 1-byte objects to each pool using rados bench.

Also available in: Atom PDF