Project

General

Profile

Cleanup #7668

remove custom googletest (gtest) copy from source tree

Added by Danny Al-Gaaf almost 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/10/2014
Due date:
% Done:

100%

Spent time:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

Remove the the potentially outdated gtest code from the source tree to keep it up-to-date:

Needed steps:
- since googletest is hosted via SVN [1], we need a copy of the repo in the github ceph project. Copy it from SVN, add documentation on how to keep it up-to-date
- verify and apply changes from current ceph git gtest to the new git repo
- remove code from ceph.git source tree
- add gtest to submodules

[1] https://code.google.com/p/googletest/source/list

History

#1 Updated by Greg Farnum almost 5 years ago

I have no expertise here and am down with making this change if it works out better, but when we initially grabbed gtest a wholesale copy was the recommended approach (or so I was told).

#2 Updated by Danny Al-Gaaf almost 4 years ago

Can someone please create an empty gtest and gmock git repository in the ceph namespace so that we can move this code there (I have no permissions to do that)? I would be much easier to handle these dependencies at least in separate git repos and include it from there as submodule.

#3 Updated by Danny Al-Gaaf almost 4 years ago

Branch with solution can be found here: https://github.com/ceph/ceph/tree/wip-da-gmock-submodule

The problem is still: I need an empty gmock and gtest repo under the github ceph account!

#5 Updated by Danny Al-Gaaf almost 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

#6 Updated by Danny Al-Gaaf almost 4 years ago

  • % Done changed from 100 to 80

There are issues with this merge on master. We need to fix gitbuilder and mirror the repos in the sepia git

#8 Updated by Danny Al-Gaaf almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF