Project

General

Profile

Bug #26861

mgr/dashboard: Email addr is set to false when RGW user is modified

Added by Volker Theile 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/rgw
Target version:
Start date:
08/06/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

When a RGW user is modified via the dashboard UI, then an empty email field is submitted with the value 'false'. Seems to be a problem while collecting the modified fields before they are submitted to the backend.

Modifying a user whit a modified max buckets field finally looks like http://localhost:4200/api/rgw/user/test4?display_name=test4&email=false&max_buckets=1001&suspended=0

A more or less equal problem in the backend was fixed with https://github.com/ceph/ceph/pull/22024 (issue https://tracker.ceph.com/issues/24142).

History

#1 Updated by Volker Theile 4 months ago

  • Assignee set to Stephan Müller
  • Regression changed from No to Yes

#2 Updated by Volker Theile 4 months ago

The behaviour of the class CdFormGroup introduced by PR 22644 is not exactly the same as the origin FormGroup. Please fix the issue in the CdFormGroup class or the RGW user form. I suggest to fix it in CdFormGroup because there is surely other code that assumes the behaviour of the origin FormGroup class (e.g. RGW bucket management). I don't understand the sense of an boolean result if the input field is of type string. The current implementation is erroneous for input fields that accept empty values.

#3 Updated by Stephan Müller about 2 months ago

  • Status changed from New to Need Review

#5 Updated by Lenz Grimmer about 1 month ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF