Project

General

Profile

Bug #21196

radosgw-admin usage show loops indefinitly

Added by Marcin Gibula 4 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
08/31/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

After updating our test cluster to luminous, 'usage show' output loops indefinitly, returning (bogus?) usage data over and over again.
Attaching first few hundred lines of an output.

In output there are references to user "anonymous" and bucket "-" (and bucket with empty name - is it even possible?) - both of them do not exist.

Note that this is not fresh install - it's preproduction cluster used for testing rolling updates, and it dates back to firefly or dumpling. It's a simple non-multisite config.

Command used for usage show is:
  1. radosgw-admin usage show --start-date="2017-08-30 20:00:00"

It did work on jewel yesterday:)

usage.log View (9.85 KB) Marcin Gibula, 08/31/2017 08:11 AM


Related issues

Copied to rgw - Backport #21698: luminous: radosgw-admin usage show loops indefinitly Resolved

History

#1 Updated by Marcin Gibula 4 months ago

Quering via REST api does not work either

#2 Updated by Yehuda Sadeh 3 months ago

  • Priority changed from Normal to High

#3 Updated by Yehuda Sadeh 3 months ago

  • Assignee set to Mark Kogan

#4 Updated by Orit Wasserman 3 months ago

  • Status changed from New to In Progress

#6 Updated by Matt Benjamin 2 months ago

  • Status changed from In Progress to Pending Backport
  • Backport set to Luminous

#7 Updated by Nathan Cutler 2 months ago

  • Backport changed from Luminous to luminous

#8 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #21698: luminous: radosgw-admin usage show loops indefinitly added

#9 Updated by Mark Kogan 2 months ago

Teuthology run:

Test Run: mkogan-2017-10-03_09:29:35-rgw-wip-rgw-21196-distro-basic-mira =================================================================
info: http://pulpito.ceph.com/mkogan-2017-10-03_09:29:35-rgw-wip-rgw-21196-distro-basic-mira/
logs: http://qa-proxy.ceph.com/teuthology/mkogan-2017-10-03_09:29:35-rgw-wip-rgw-21196-distro-basic-mira/
failed: 21
dead: 0
running: 0
waiting: 0
queued: 0
passed: 204

#10 Updated by Marcin Gibula 13 days ago

With new version of luminous (ceph version 12.2.2 (cf0baeeeeba3b47f9427c6c97e2144b094b7e5ba) luminous (stable) ), it's still broken for me.

#11 Updated by Marcin Gibula 13 days ago

Marcin Gibula wrote:

With new version of luminous (ceph version 12.2.2 (cf0baeeeeba3b47f9427c6c97e2144b094b7e5ba) luminous (stable) ), it's still broken for me.

However, now it does not produce infinite output, it just hangs after printing two entries.

#12 Updated by Marcin Gibula 13 days ago

After playing some more with it. It actually completes, just take much longer than usual. So I think this bug can be closed, I'll open new one for regression in usage show execution time when I gather more info.

#13 Updated by Nathan Cutler 3 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF