Project

General

Profile

Bug #20177

RGW lifecycle not expiring objects due to permissions on lc pool

Added by Anton Oks 5 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Target version:
Start date:
06/04/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
kraken
Needs Doc:
No


Related issues

Copied to rgw - Backport #20967: luminous: RGW lifecycle not expiring objects due to permissions on lc pool Resolved

History

#1 Updated by Matt Benjamin 4 months ago

Some notes (cribbed from email by Dan Gryniewicz):

The lifecycle config looks sane; Dan, do you see anything here?

objects are checked for expiration once per day. The start time for processing is configured by "rgw lifecycle work time", and defaults to midnight.

For the record, if you are just testing, we introduced a debug harness (used in Teuthology) that will make each "day" pass in a configurable number of seconds. This should not be used in any production setup, since the overhead can be quite high, but it can be used to avoid waiting a whole day when testing the feature. The configurable is "rgw lc debug interval"

#2 Updated by Matt Benjamin 4 months ago

is this still an ongoing issue?

#3 Updated by Yehuda Sadeh 4 months ago

  • Subject changed from RGW lifecycle not expiring objects to RGW lifecycle not expiring objects due to permissions on lc pool

http://lists.ceph.com/pipermail/ceph-users-ceph.com/2017-June/018933.html

Need to make sure that we log errors, so that these problems are not just silently hidden.

#4 Updated by Yehuda Sadeh 4 months ago

  • Priority changed from Urgent to High

#5 Updated by Orit Wasserman 3 months ago

  • Assignee changed from Yehuda Sadeh to Abhishek Lekshmanan

It is the same as the reshard error, we should init to namespace.
The same applys to the roles pool

#6 Updated by Orit Wasserman 3 months ago

  • Status changed from New to In Progress

#7 Updated by Orit Wasserman 3 months ago

  • Assignee changed from Abhishek Lekshmanan to Orit Wasserman

#8 Updated by Orit Wasserman 2 months ago

  • Status changed from In Progress to Need Review

#9 Updated by Nathan Cutler 2 months ago

  • Status changed from Need Review to Pending Backport
  • Backport changed from c10.2.8 to luminous

#10 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #20967: luminous: RGW lifecycle not expiring objects due to permissions on lc pool added

#11 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF