Project

General

Profile

Bug #19497

osd_scrub_sleep option blocks op thread in jewel + later

Added by Josh Durgin 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OSD
Target version:
-
Start date:
04/04/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel, kraken
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Just like snap trimming, when scrubbing was moved into the unified op queue, its sleep option was not changed, so it now blocks osd ops rather than just pausing scrubbing.

This sleep should be moved from PG::scrub() into the scrub state machine, and made async, just like it was for snap trimming - see http://tracker.ceph.com/issues/19241


Related issues

Copied to Ceph - Backport #20032: jewel: osd_scrub_sleep option blocks op thread in jewel + later Resolved
Copied to Ceph - Backport #20033: kraken: osd_scrub_sleep option blocks op thread in jewel + later Resolved

History

#1 Updated by Brad Hubbard 7 months ago

  • Assignee set to Brad Hubbard

#2 Updated by Brad Hubbard 6 months ago

  • Status changed from New to In Progress

#3 Updated by Kefu Chai 6 months ago

  • Status changed from In Progress to Pending Backport

#4 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #20032: jewel: osd_scrub_sleep option blocks op thread in jewel + later added

#5 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #20033: kraken: osd_scrub_sleep option blocks op thread in jewel + later added

#7 Updated by Nathan Cutler 5 months ago

Brad Hubbard wrote:

Please see https://github.com/ceph/ceph/pull/15217 also

Brad, are you saying that https://github.com/ceph/ceph/pull/14886 and https://github.com/ceph/ceph/pull/15217 should be backported together once the latter has been merged?

#8 Updated by Brad Hubbard 5 months ago

Hi Nathan, Yes, https://github.com/ceph/ceph/pull/14886 causes problems (proliferation of threads) and should not be backported by itself.

#9 Updated by Brad Hubbard 5 months ago

https://github.com/ceph/ceph/pull/15217 has merged and I have set http://tracker.ceph.com/issues/19986 pending backport via this tracker. Hope that's OK?

#10 Updated by Nathan Cutler 5 months ago

@Brad - yes, when you open the backport PR, just mention both backport tracker issues in the commit message ;-)

I say "when you open" because I looked at the cherry pick of PR#14886 to jewel. . . and it's non-trivial. It conflicts, e.g., with https://github.com/ceph/ceph/commit/b7e77996586daa46da6be0bfbb8c2b93e203a83a and I don't know if that's a dependency.

Can I assign the backport trackers to you?

#11 Updated by Brad Hubbard 5 months ago

@Nathan, Yes mate, please do and I'll see what I can do about it. b7e77996586daa46da6be0bfbb8c2b93e203a83a shouldn't be a dependency but it's also my code so I'm definitely best placed to do the work :)

#12 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF