Project

General

Profile

Bug #19241

osd_snap_trim_sleep option does not work

Added by Josh Durgin 7 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
OSD
Target version:
-
Start date:
03/08/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel, kraken
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

With large numbers of snapshots, this can result in snapshot trimming overwhelming client i/o. The snap trim sleep option no longer works in jewel since the snap trim queue was removed and snap trim was moved into the main op queue.

Fixed in master by: https://github.com/ceph/ceph/pull/13594


Related issues

Copied to Ceph - Backport #19328: jewel: osd_snap_trim_sleep option does not work Resolved
Copied to Ceph - Backport #19329: kraken: osd_snap_trim_sleep option does not work Resolved

History

#1 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #19328: jewel: osd_snap_trim_sleep option does not work added

#2 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #19329: kraken: osd_snap_trim_sleep option does not work added

#3 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF