Project

General

Profile

Bug #18844

import-diff failed: (33) Numerical argument out of domain - if image size of the child is larger than the size of its parent

Added by Bernhard J. M. Grün over 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
02/07/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
import, import-diff, rbd
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
rbd
Pull request ID:

Description

Steps to setup the test case (create a basic image):
rbd create vms/test -s 1G
rbd snap create vms/test@snap
rbd snap protect vms/test@snap

Steps ro reproduce the bug:
rbd resize vms/test-larger --size 8G
rbd create backup/test-larger -s 1
rbd export-diff --no-progress --whole-object vms/test-larger - | rbd import-diff - backup/test-larger

Result: (not as expected)
import-diff failed: (33) Numerical argument out of domain

Please have a look at full error output which is attached to this ticket.

Steps to validate that import-diff works correctly on the cluster if no resize happend:
rbd clone vms/test@snap vms/test-not-larger
rbd create backup/test-not-larger -s 1
rbd export-diff --no-progress --whole-object vms/test-not-larger - | rbd import-diff - backup/test-not-larger

Result: (as expected)
Importing image diff: 100% complete...done.

Environment:
Cluster runs Ceph 10.2.5 on CentOS 7.3.

dump-ceph.txt View (24.3 KB) Bernhard J. M. Grün, 02/07/2017 12:05 PM


Related issues

Copied to rbd - Backport #23607: luminous: import-diff failed: (33) Numerical argument out of domain - if image size of the child is larger than the size of its parent Resolved
Copied to rbd - Backport #23608: jewel: import-diff failed: (33) Numerical argument out of domain - if image size of the child is larger than the size of its parent Closed

History

#1 Updated by Tianqing Li over 2 years ago

how do you create vms/test-larger?

#2 Updated by Bernhard J. M. Grün over 2 years ago

Whops - I forgot that one line. It is basically the same as in the validate case.

These are the all steps to reproduce the bug:

rbd clone vms/test@snap vms/test-larger
rbd resize vms/test-larger --size 8G
rbd create backup/test-larger -s 1
rbd export-diff --no-progress --whole-object vms/test-larger - | rbd import-diff - backup/test-larger

Sorry for the inconvenience

#3 Updated by Nathan Cutler over 2 years ago

  • Target version deleted (v10.2.6)

#4 Updated by Greg Farnum about 2 years ago

  • Project changed from Ceph to rbd
  • Category deleted (librbd)

#5 Updated by Mykola Golub about 2 years ago

  • Status changed from New to Need More Info

There have been several related fixes in v10.2.6 [1], one of them fixed the crashes you observed [2]

So I believe the issue is fixed. I can't reproduce it on the recent jewel. Bernhard, is there a chance you can confirm 10.2.6 or 10.2.7 works for you?

[1] http://docs.ceph.com/docs/master/release-notes/#v10-2-6-jewel
[2] http://tracker.ceph.com/issues/18200

#6 Updated by Jason Dillaman over 1 year ago

  • Status changed from Need More Info to Resolved

#7 Updated by Jason Dillaman about 1 year ago

  • Status changed from Resolved to In Progress
  • Assignee set to Jason Dillaman
  • Backport set to luminous,jewel

If the 'rbd export-diff' is corrupt, it can result in that error:

$ echo "" | rbd import-diff - lun0
rbd: import-diff failed: (33) Numerical argument out of domain

#8 Updated by Jason Dillaman about 1 year ago

  • Status changed from In Progress to Need Review

#9 Updated by Mykola Golub about 1 year ago

  • Status changed from Need Review to Pending Backport

#10 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #23607: luminous: import-diff failed: (33) Numerical argument out of domain - if image size of the child is larger than the size of its parent added

#11 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #23608: jewel: import-diff failed: (33) Numerical argument out of domain - if image size of the child is larger than the size of its parent added

#12 Updated by Jason Dillaman 9 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF