Project

General

Profile

Bug #18725

"zonegroupmap set" does not work

Added by Mustafa Muhammad 3 months ago. Updated about 1 month ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/28/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

I used:
radosgw-admin zonegroupmap get > zonegroupmap.json

then changed the json file, then used:
radosgw-admin zonegroupmap set < zonegroupmap.json

and the map didn't change, I also tried:
radosgw-admin regionmap update --commit

this didn't change it too.

It works if I change the zonegroup then update.


Related issues

Copied to Backport #19478: jewel: "zonegroupmap set" does not work In Progress
Copied to Backport #19479: kraken: rgw: "zonegroupmap set" does not work In Progress

History

#1 Updated by Yehuda Sadeh 2 months ago

What version are you running? This command is an artifact from multisite v1 and probably doesn't work and should be removed. If you're not trying to use v2 and not v1, try to follow the new multisite docs here:

http://docs.ceph.com/docs/jewel/radosgw/multisite/

#2 Updated by Matt Benjamin about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to Casey Bodley

triage: propose to remove this command

#3 Updated by Casey Bodley about 1 month ago

  • Status changed from In Progress to Need Review

#4 Updated by Casey Bodley about 1 month ago

  • Status changed from Need Review to Pending Backport
  • Backport set to jewel kraken

#5 Updated by Nathan Cutler 20 days ago

#6 Updated by Nathan Cutler 20 days ago

  • Copied to Backport #19479: kraken: rgw: "zonegroupmap set" does not work added

Also available in: Atom PDF