Project

General

Profile

Bug #18638

OSD metadata reports filestore when using bluestore

Added by Wido den Hollander 9 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
OSD
Target version:
-
Start date:
01/23/2017
Due date:
% Done:

0%

Source:
Tags:
osd,bluestore,metadata
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
kraken
Needs Doc:
No

Description

When testing with Kraken 11.2.0 I checked the metadata of my OSDs running BlueStore, but found out they report filestore as objectstore.

root@alpha:~# ceph osd metadata 0
{
    "id": 0,
    "arch": "x86_64",
    "back_addr": "[2001:db8::100]:6801\/3634",
    "ceph_version": "ceph version 11.2.0 (f223e27eeb35991352ebc1f67423d4ebc252adb7)",
    "cpu": "Intel(R) Core(TM) i5-3427U CPU @ 1.80GHz",
    "distro": "ubuntu",
    "distro_description": "Ubuntu 16.04.1 LTS",
    "distro_version": "16.04",
    "front_addr": "[2001:db8::100]:6800\/3634",
    "hb_back_addr": "[2001:db8::100]:6802\/3634",
    "hb_front_addr": "[2001:db8::100]:6803\/3634",
    "hostname": "alpha",
    "kernel_description": "#50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016",
    "kernel_version": "4.4.0-31-generic",
    "mem_swap_kb": "522236",
    "mem_total_kb": "500192",
    "os": "Linux",
    "osd_data": "\/var\/lib\/ceph\/osd\/ceph-0",
    "osd_journal": "\/var\/lib\/ceph\/osd\/ceph-0\/journal",
    "osd_objectstore": "filestore" 
}
root@alpha:~#

Seems that the OSD uses the osd_objectstore configuration directive and passes that in the metadata.


Related issues

Copied to Ceph - Backport #18677: kraken: OSD metadata reports filestore when using bluestore Resolved

History

#1 Updated by Sage Weil 9 months ago

  • Status changed from New to Pending Backport
  • Priority changed from Normal to Urgent
  • Backport set to kraken

#2 Updated by Loic Dachary 9 months ago

  • Copied to Backport #18677: kraken: OSD metadata reports filestore when using bluestore added

#4 Updated by Shinobu Kinjo 8 months ago

@Sage
Fix needs to be backported into jewel as well?

https://github.com/ceph/ceph/blob/jewel/src/osd/OSD.cc#L4873

#5 Updated by Sage Weil 8 months ago

Eh, I'm not too worried about jewel since nobody should really be using that bluestore code anymore. We certainly could, tho.

#6 Updated by Shinobu Kinjo 8 months ago

Well, that's good point =)

#7 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF