Project

General

Profile

Bug #18313

upstart: radosgw-all does not start on boot if ceph-base is not installed

Added by Ken Dreyer 10 months ago. Updated 16 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
12/20/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

The "radosgw-all" Upstart service depends on the "ceph-all" service in order to trigger a start operation. ceph-all.conf ships in the "ceph-base" package (in Jewel and newer) or the "ceph" package (Hammer and older), and this is not an explicit radosgw package dependency. This means that the radosgw-all Upstart service would not start on boot unless the ceph-base package was also explicitly installed.

We can break this dependency by starting radosgw-all according to the system's runlevel, rather than only listening for the ceph-all starting signal.

(From what I can tell from Git, this has been an issue on Ubuntu since the introduction of Upstart support)


Related issues

Copied to devops - Backport #18853: jewel: upstart: radosgw-all does not start on boot if ceph-base is not installed Resolved
Copied to devops - Backport #18854: hammer: upstart: radosgw-all does not start on boot if ceph-base is not installed Rejected

History

#2 Updated by Ken Dreyer 10 months ago

  • Backport set to jewel, hammer

#3 Updated by Ken Dreyer 10 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Kefu Chai 9 months ago

  • Status changed from Need Review to Pending Backport

might want to note the user visible change in release notes when backporting this change to jewel and hammer where upstart could be still being used.

#5 Updated by Loic Dachary 9 months ago

  • Copied to Backport #18853: jewel: upstart: radosgw-all does not start on boot if ceph-base is not installed added

#6 Updated by Loic Dachary 9 months ago

  • Copied to Backport #18854: hammer: upstart: radosgw-all does not start on boot if ceph-base is not installed added

#7 Updated by Kefu Chai 16 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF