Project

General

Profile

Bug #17198

helgrind: TestLibRBD.TestIOPP potential deadlock closing an image with read-ahead enabled

Added by Jason Dillaman over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
09/02/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://qa-proxy.ceph.com/teuthology/trociny-2016-09-01_18:31:51-rbd-wip-mgolub-testing---basic-vps/395528/teuthology.log

If the readahead is the last in-flight IO operation while the image is being closed, it's possible to cause a deadlock attempting to shut down the cache. Since cache read completions hold the cache_lock upon callback, it is required delay the processing of the read completion (i.e. via create_async_context_callback) to prevent such issues. This is handled on the normal IO read path but it is missing on the readahead path.


Related issues

Copied to rbd - Backport #17384: jewel: helgrind: TestLibRBD.TestIOPP potential deadlock closing an image with read-ahead enabled Resolved

History

#1 Updated by Jason Dillaman over 2 years ago

  • Subject changed from TestLibRBD.TestIOPP: potential deadlock closing an image with read-ahead enabled to helgrind: TestLibRBD.TestIOPP potential deadlock closing an image with read-ahead enabled

#2 Updated by Jason Dillaman over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#3 Updated by Jason Dillaman over 2 years ago

  • Status changed from In Progress to Need Review

#4 Updated by Mykola Golub over 2 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #17384: jewel: helgrind: TestLibRBD.TestIOPP potential deadlock closing an image with read-ahead enabled added

#6 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF