Project

General

Profile

Feature #16973

Log path as well as ino when detecting metadata damage

Added by John Spray about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
fsck/damage handling
Target version:
-
Start date:
08/09/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Reviewed:
User Impact:
Affected Versions:
Release:
Component(FS):
MDS
Needs Doc:

Description

Currently our cluster log messages look like this:

2016-08-03 03:47:16.830795 mds.0 172.21.4.136:6800/28762 706 : cluster [ERR] dir 1000022a401 object missing on disk; some files may be lost

Usually we have enough information at runtime to include the path in that output


Related issues

Copied to fs - Backport #17246: jewel: Log path as well as ino when detecting metadata damage Resolved

History

#1 Updated by John Spray about 1 year ago

  • Status changed from New to Need Review

#2 Updated by John Spray about 1 year ago

  • Status changed from Need Review to Testing
  • Backport set to jewel

Marking for backport because although it's not a bugfix, it's a supportability thing.

#3 Updated by John Spray about 1 year ago

  • Status changed from Testing to Pending Backport

#4 Updated by Loic Dachary about 1 year ago

  • Copied to Backport #17246: jewel: Log path as well as ino when detecting metadata damage added

#5 Updated by Loic Dachary 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF