Project

General

Profile

Bug #16740

Cannot disable journaling or remove non-mirrored, "non-primary" image

Added by Jason Dillaman 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
07/19/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Use rbd-mirror to create a non-primary image. If the 'rbd_mirroring' object is removed, this image will now be treated as if mirroring is disabled. However, no actions can be taken because the journal flags it as a non-primary image. librbd needs to recover from this situation by also ensuring that mirroring is enabled against the image before determining that it is non-primary.


Related issues

Copied to Backport #17060: jewel: Cannot disable journaling or remove non-mirrored, "non-primary" image Resolved

History

#1 Updated by Jason Dillaman 7 months ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman 7 months ago

  • Status changed from In Progress to Need Review

#3 Updated by Mykola Golub 6 months ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Loic Dachary 6 months ago

  • Copied to Backport #17060: jewel: Cannot disable journaling or remove non-mirrored, "non-primary" image added

#5 Updated by Loic Dachary 6 months ago

  • Status changed from Pending Backport to Resolved

#6 Updated by Jason Dillaman 5 months ago

  • Status changed from Resolved to Pending Backport
  • Needs Doc set to No

#7 Updated by Loic Dachary 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF