Project

General

Profile

Bug #16709

No output for "ceph mds rmfailed 0 --yes-i-really-mean-it" command

Added by Rohith Radhakrishnan over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Administration/Usability
Target version:
-
Start date:
07/18/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel, kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel
Component(FS):
Needs Doc:
No

Description

there is no output for the command ceph mds rmfailed 0 --yes-i-really-mean-it. The command is successful how many ever times we run it. There is nothing displayed to actually show if the command is successful or not or whether the mds has actually been failed.

ceph mds rmfailed 0 --yes-i-really-mean-it
ems@rack2-client-3:~$ ceph mds rmfailed 1 --yes-i-really-mean-it
Error EINVAL: Rank '1' not foundinvalid role '1'
ems@rack2-client-3:~$ ceph mds rmfailed 0 --yes-i-really-mean-it
ems@rack2-client-3:~$ ceph mds rmfailed 0 --yes-i-really-mean-it
ems@rack2-client-3:~$ ceph mds rmfailed 0 --yes-i-really-mean-it


Related issues

Copied to fs - Backport #19482: jewel: No output for "ceph mds rmfailed 0 --yes-i-really-mean-it" command Resolved
Copied to fs - Backport #19483: kraken: No output for "ceph mds rmfailed 0 --yes-i-really-mean-it" command Resolved

History

#1 Updated by John Spray over 1 year ago

Without looking at the code, I would imagine that you're seeing EINVAL for rank 1 because there is no such rank (so it doesn't make sense to try and remove it from the failed set).

You're seeing 0 for rank 0 because Ceph CLI commands are idempotent, so whenever we have a removal -type operation we will return success if it is not present.

This isn't a bug as such but probably could be a bit friendlier by printing a message saying that the rank you're asking to remove from the failed set was already removed.

#2 Updated by Rohith Radhakrishnan over 1 year ago

Yes that would be ideal. as of now we cannot be sure if it has been actually removed or not.

#3 Updated by Greg Farnum over 1 year ago

  • Category set to Administration/Usability

#4 Updated by John Spray 9 months ago

  • Status changed from New to Need Review
  • Backport set to jewel, kraken

#5 Updated by John Spray 8 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #19482: jewel: No output for "ceph mds rmfailed 0 --yes-i-really-mean-it" command added

#7 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #19483: kraken: No output for "ceph mds rmfailed 0 --yes-i-really-mean-it" command added

#8 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF