Project

General

Profile

Bug #16561

FAILED assert(object_no < m_object_map.size())

Added by Jason Dillaman over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
06/30/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Steps to reproduce:
1. clone a large image
2. create a snapshot on the clone
3. shrink the clone twice

The semi-recent addition of deep-flatten incorrectly computes the copy-up region using the largest parent overlap. Since the first shrink would have handled the copy-up for the trimmed region, always use the most recent parent overlap. Using the snapshot's overlap will result in an attempt to go beyond the current object map.


Related issues

Copied to rbd - Backport #16593: jewel: FAILED assert(object_no < m_object_map.size()) Resolved

History

#1 Updated by Jason Dillaman over 2 years ago

  • Description updated (diff)

#2 Updated by Jason Dillaman over 2 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Mykola Golub over 2 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #16593: jewel: FAILED assert(object_no < m_object_map.size()) added

#5 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF