Project

General

Profile

Bug #16529

"[ FAILED ] TestClsRbd.mirror_image" in upgrade:jewel-x-master-distro-basic-vps

Added by Yuri Weinstein over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
06/29/2016
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/jewel-x
Pull request ID:

Description

Run: http://pulpito.ceph.com/teuthology-2016-06-29_04:20:02-upgrade:jewel-x-master-distro-basic-vps/
Jobs: 283220, 283214
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2016-06-29_04:20:02-upgrade:jewel-x-master-distro-basic-vps/283214/teuthology.log

2016-06-29T05:28:40.648 INFO:tasks.workunit.client.1.vpm139.stdout:test/cls_rbd/test_cls_rbd.cc:1384: Failure
2016-06-29T05:28:40.648 INFO:tasks.workunit.client.1.vpm139.stdout:Value of: mirror_image_set(&ioctx, "image_id2", image2)
2016-06-29T05:28:40.648 INFO:tasks.workunit.client.1.vpm139.stdout:  Actual: -2
2016-06-29T05:28:40.648 INFO:tasks.workunit.client.1.vpm139.stdout:Expected: 0
2016-06-29T05:28:40.649 INFO:tasks.workunit.client.1.vpm139.stdout:[  FAILED  ] TestClsRbd.mirror_image (14 ms)

Related issues

Copied to rbd - Backport #17062: jewel: "[ FAILED ] TestClsRbd.mirror_image" in upgrade:jewel-x-master-distro-basic-vps Resolved

History

#1 Updated by Jason Dillaman over 2 years ago

  • Project changed from Ceph to rbd

#2 Updated by Loic Dachary over 2 years ago

http://pulpito.ceph.com/teuthology-2016-07-17_04:20:03-upgrade:jewel-x-master-distro-basic-vps/319486/
http://pulpito.ceph.com/teuthology-2016-07-17_04:20:03-upgrade:jewel-x-master-distro-basic-vps/319492/

2016-07-17T09:32:57.647 INFO:tasks.workunit.client.1.vpm063.stdout:test/cls_rbd/test_cls_rbd.cc:1384: Failure
2016-07-17T09:32:57.647 INFO:tasks.workunit.client.1.vpm063.stdout:Value of: mirror_image_set(&ioctx, "image_id2", image2)
2016-07-17T09:32:57.647 INFO:tasks.workunit.client.1.vpm063.stdout:  Actual: -2
2016-07-17T09:32:57.647 INFO:tasks.workunit.client.1.vpm063.stdout:Expected: 0
2016-07-17T09:32:57.648 INFO:tasks.workunit.client.1.vpm063.stdout:[  FAILED  ] TestClsRbd.mirror_image (16 ms)

#3 Updated by Jason Dillaman over 2 years ago

The upgrade test installs 10.2.0, upgrades the OSDs to a point release but keeps the test_cls_rbd at 10.2.0. There was a bug fix introduced in cls_rbd which now results in a new error code being returned. Since it is impossible to update the v10.2.0 test_cls_rbd to account for this error condition, I am not sure how to fix this test.

#5 Updated by Jason Dillaman over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#6 Updated by Jason Dillaman over 2 years ago

  • Backport set to jewel

#7 Updated by Jason Dillaman over 2 years ago

  • Status changed from In Progress to Need Review

#8 Updated by Mykola Golub over 2 years ago

  • Status changed from Need Review to Pending Backport

https://github.com/ceph/ceph/pull/10714 is merged. It should be backported to jewel before https://github.com/ceph/ceph-qa-suite/pull/1116 is merged.

#9 Updated by Loic Dachary over 2 years ago

  • Copied to Backport #17062: jewel: "[ FAILED ] TestClsRbd.mirror_image" in upgrade:jewel-x-master-distro-basic-vps added

#10 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Need Review

@Mykola the Pending Backport status should only be set when the corresponding commits are merged in master. This status prompts the stable release team to backport to jewel and you would not want that to happen before the commits are actually in master ;-)

#11 Updated by Mykola Golub over 2 years ago

  • Status changed from Need Review to Pending Backport

#12 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF