Project

General

Profile

Bug #16522

install-deps.sh fails on openSUSE Tumbleweed

Added by Jan Fajerski almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/29/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

install-deps-sh script checks for presence of apt-get to install minimal dependecies for Debian. On Tumbleweed this test succeeds since apt-get is a link to aptitude. The script the attempts to install package 'equivs', which fails since no provider can be found.

To reproduce:
Clone ceph repo on a fresh Tumbleweed installation and run install-deps.sh.


Related issues

Related to devops - Bug #18198: build/ops: install-deps.sh based on /etc/os-release Resolved

History

#1 Updated by Jan Fajerski almost 3 years ago

proposed a fix: https://github.com/ceph/ceph/pull/10013

It might be better to base OS detection on something else than the rpesence of a package manager. Maybe /etc/os-release?

#3 Updated by Nathan Cutler almost 3 years ago

  • Status changed from New to Need Review

#4 Updated by Nathan Cutler over 2 years ago

  • Status changed from Need Review to Resolved
  • Source changed from other to Community (dev)

#5 Updated by Nathan Cutler over 2 years ago

  • Related to Bug #18198: build/ops: install-deps.sh based on /etc/os-release added

Also available in: Atom PDF