Project

General

Profile

Bug #16445

Whitelist EBUSY error from "snap unprotect" for journal replay

Added by Jason Dillaman almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
06/23/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

If the OpFinishEvent's return code is "-EBUSY" for a snap unprotect event, do not attempt to replay the snap unprotect operation since it failed after detecting child images.


Related issues

Copied to rbd - Backport #16485: jewel: Whitelist EBUSY error from "snap unprotect" for journal replay Resolved

History

#1 Updated by Jason Dillaman almost 3 years ago

  • Status changed from In Progress to Need Review

#2 Updated by Mykola Golub almost 3 years ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Loic Dachary almost 3 years ago

  • Copied to Backport #16485: jewel: Whitelist EBUSY error from "snap unprotect" for journal replay added

#4 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF