Project

General

Profile

Bug #16378

async messenger hang in rados/singleton-nomsgr/{rados.yaml all/msgr.yaml}

Added by Samuel Just about 3 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
06/17/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

sjust@teuthology:/a/yuriw-2016-06-15_15:52:06-rados-master_2016_06_15-distro-basic-smithi/262588

History

#1 Updated by Samuel Just about 3 years ago

  • Assignee set to Haomai Wang

#2 Updated by Haomai Wang about 3 years ago

  • Category set to msgr

This is a test program problem and not related to actual env.

Currently test program will create connection between A(Client) and B(Server) at first. Later we will get connection from B to A and send message. But A->B connect try will cause B->A connection stuck into STATE_WAIT. Unluckily A->B connection due to error injection and fall down STANDBY. At last, A->B is STANDBY and B->A is STATE_WAIT. So this test program will hang forever.

#3 Updated by Haomai Wang about 3 years ago

  • Status changed from New to In Progress

#4 Updated by Haomai Wang about 3 years ago

  • Status changed from In Progress to Need Review

#5 Updated by Samuel Just about 3 years ago

sjust@teuthology:/a/samuelj-2016-06-21_10:29:56-rados-wip-sam-testing-distro-basic-smithi/268922

#6 Updated by Samuel Just about 3 years ago

  • Status changed from Need Review to Resolved

#7 Updated by Greg Farnum 4 months ago

  • Project changed from Ceph to Messengers
  • Category deleted (msgr)

Also available in: Atom PDF