Project

General

Profile

Bug #16289

"rbd: create error: (38) Function not implemented" in upgrade:client

Added by Mykola Golub about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
06/14/2016
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
jewel, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://qa-proxy.ceph.com/teuthology/trociny-2016-06-14_01:56:12-upgrade:client-upgrade-wip-mgolub-testing---basic-vps/258010/teuthology.log

2016-06-14T02:59:23.811 INFO:tasks.workunit.client.0.vpm199.stderr:+ rbd create sparse --size 4
2016-06-14T02:59:23.812 INFO:tasks.workunit.client.0.vpm199.stdout:zeros export to sparse file
2016-06-14T02:59:23.865 INFO:tasks.workunit.client.0.vpm199.stderr:2016-06-14 09:59:23.854911 7f5c6a529d80 -1 librbd: error writing header: (38) Function not implemented
2016-06-14T02:59:23.878 INFO:tasks.workunit.client.0.vpm199.stderr:rbd: create error: (38) Function not implemented
2016-06-14T02:59:23.880 INFO:tasks.workunit:Stopping ['rbd/import_export.sh'] on client.0...

Related issues

Copied to rbd - Backport #16324: jewel: rbd: create error: (38) Function not implemented in upgrade:client Resolved
Copied to rbd - Backport #16325: hammer: "rbd: create error: (38) Function not implemented" in upgrade:client Resolved

History

#1 Updated by Mykola Golub about 3 years ago

I suppose the suite should be fixed to set rbd_default_features client config option to only features available on old version?

#2 Updated by Jason Dillaman about 3 years ago

@Mykola: agreed -- the 'create' call should just pass '--image-feature layering'

#3 Updated by Mykola Golub about 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Mykola Golub

#4 Updated by Mykola Golub about 3 years ago

Looking at it more closely, it fails on hammer, where all features from RBD_CREATE_ARGS= (--image-feature layering,exclusive-lock,object-map) are available. So RBD_CREATE_ARGS looks ok and the problem is actually with `rbd create sparse --size 4` which is called without $RBD_CREATE_ARGS. Checking this assumption.

#5 Updated by Mykola Golub about 3 years ago

  • Backport set to jewel

#6 Updated by Mykola Golub about 3 years ago

  • Status changed from In Progress to Need Review
  • Source changed from other to Q/A
  • Backport changed from jewel to jewel, hammer

#7 Updated by Mykola Golub about 3 years ago

It needs to be also backported to hammer, as the affected suite uses hammer branch for the workunit.

#8 Updated by Jason Dillaman about 3 years ago

  • Status changed from Need Review to Pending Backport

#9 Updated by Mykola Golub about 3 years ago

  • Copied to Backport #16324: jewel: rbd: create error: (38) Function not implemented in upgrade:client added

#10 Updated by Mykola Golub about 3 years ago

  • Copied to Backport #16325: hammer: "rbd: create error: (38) Function not implemented" in upgrade:client added

#11 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF