Project

General

Profile

Bug #16067

client: InvalidWrite in put_qtree

Added by John Spray over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
05/28/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
Needs Doc:
No

Description

Like #16066, this seen in test branch with client quota enabled by default.

http://pulpito.ceph.com/jspray-2016-05-28_13:42:42-fs-wip-jcsp-testing-20160527b---basic-mira/220215

<error>
  <unique>0x3</unique>
  <tid>1</tid>
  <kind>InvalidRead</kind>
  <what>Invalid read of size 4</what>
  <stack>
    <frame>
      <ip>0x2ACE37</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>_put</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Inode.h</file>
      <line>90</line>
    </frame>
    <frame>
      <ip>0x2ACE37</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>invalidate</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Inode.h</file>
      <line>149</line>
    </frame>
    <frame>
      <ip>0x2ACE37</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::put_qtree(Inode*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>11959</line>
    </frame>
    <frame>
      <ip>0x2CE9A2</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::put_inode(Inode*, int)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2770</line>
    </frame>
    <frame>
      <ip>0x2D88AB</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::close_dir(Dir*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2809</line>
    </frame>
    <frame>
      <ip>0x2D9312</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::unlink(Dentry*, bool, bool)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2895</line>
    </frame>
    <frame>
      <ip>0x2D9540</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::trim_dentry(Dentry*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>712</line>
    </frame>
    <frame>
      <ip>0x2D9AB4</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::trim_cache(bool)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>650</line>
    </frame>
    <frame>
      <ip>0x3103A2</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::unmount()</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>5593</line>
    </frame>
    <frame>
      <ip>0x29D0C4</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>main</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src</dir>
      <file>ceph_fuse.cc</file>
      <line>266</line>
    </frame>
  </stack>
  <auxwhat>Address 0xd4c0b98 is 24 bytes inside a block of size 40 free'd</auxwhat>
  <stack>
    <frame>
      <ip>0xA5802BC</ip>
      <obj>/usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so</obj>
      <fn>operator delete(void*)</fn>
    </frame>
    <frame>
      <ip>0x2ACF2F</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>_put</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Inode.h</file>
      <line>93</line>
    </frame>
    <frame>
      <ip>0x2ACF2F</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>set_parent</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Inode.h</file>
      <line>134</line>
    </frame>
    <frame>
      <ip>0x2ACF2F</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>invalidate</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Inode.h</file>
      <line>148</line>
    </frame>
    <frame>
      <ip>0x2ACF2F</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::put_qtree(Inode*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>11959</line>
    </frame>
    <frame>
      <ip>0x2CE9A2</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::put_inode(Inode*, int)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2770</line>
    </frame>
    <frame>
      <ip>0x2D88AB</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::close_dir(Dir*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2809</line>
    </frame>
    <frame>
      <ip>0x2D9312</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::unlink(Dentry*, bool, bool)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>2895</line>
    </frame>
    <frame>
      <ip>0x2D9540</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::trim_dentry(Dentry*)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>712</line>
    </frame>
    <frame>
      <ip>0x2D9AB4</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::trim_cache(bool)</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>650</line>
    </frame>
    <frame>
      <ip>0x3103A2</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>Client::unmount()</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src/client</dir>
      <file>Client.cc</file>
      <line>5593</line>
    </frame>
    <frame>
      <ip>0x29D0C4</ip>
      <obj>/usr/bin/ceph-fuse</obj>
      <fn>main</fn>
      <dir>/srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-10.2.0-1432-g387a52d/src</dir>
      <file>ceph_fuse.cc</file>
      <line>266</line>
    </frame>
  </stack>
</error>

History

#1 Updated by Sage Weil over 1 year ago

  • Priority changed from Normal to Urgent

#2 Updated by Greg Farnum over 1 year ago

Any chance this is because of #16066, or at least resolved by the associated PR?

#3 Updated by John Spray over 1 year ago

Greg: yes, I expect the big quotatree patch will fix both.

#4 Updated by John Spray over 1 year ago

  • Status changed from New to Resolved

(resolved via http://tracker.ceph.com/issues/16066, track backport there)

Also available in: Atom PDF