Project

General

Profile

Bug #16014

test fails due to "The UNIX domain socket path"

Added by Kefu Chai over 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
05/25/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

see https://jenkins.ceph.com/job/ceph-pull-requests/6156/console

FAIL: test/ceph_objectstore_tool.py 

 -1> 2016-05-25 08:11:25.161032 2b6fd064ff80 -1 asok(0x2b6fd0654580) AdminSocketConfigObs::init: 
failed: AdminSocket::bind_and_listen: The UNIX domain socket path
/home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph_objectstore_tool_dir
/out/client.admin.12750.asok is too long! The maximum length on this system is 107
     0> 2016-05-25 08:11:25.221041 2b6fdce07700 -1 *** Caught signal (Segmentation fault) **
 in thread 2b6fdce07700 thread_name:service

 ceph version 10.2.0-1322-g56f4c19 (56f4c1959eede245b926464e7758604a5261fb54)

Related issues

Duplicated by Ceph - Bug #19116: Sporadic segfaults in lockdep_locked on startup Duplicate 03/01/2017
Copied to Ceph - Backport #18011: jewel: test fails due to "The UNIX domain socket path" Resolved

History

#1 Updated by Kefu Chai over 1 year ago

maybe we should introduce yet another env variable CEPH_TEST_DIR which is set in the Makefile to a temp dir under "/tmp", and populate it to all tests which creates a ceph cluster for testing.

#2 Updated by Loic Dachary over 1 year ago

It's a duplicate of #15249

#3 Updated by Kefu Chai over 1 year ago

  • Status changed from Verified to Duplicate

#4 Updated by Loic Dachary 11 months ago

  • Status changed from Duplicate to Verified
  • Priority changed from Normal to Urgent
  • Needs Doc set to No

marking as urgent and reopening because it happens often on make check runs by jenkins and asking jenkins to run the job using shorter directory names has been politely declined. It makes more sense to write test using shorter directory paths so that jenkins can use longer directory paths.

https://jenkins.ceph.com/job/ceph-pull-requests/14333/console

/home/jenkins-build/build/workspace/ceph-pull-requests/build/ceph_objectstore_tool_dir/out/client.admin.5642.asok is too long! The maximum length on this system is 107

#5 Updated by Loic Dachary 11 months ago

  • Backport set to jewel

#6 Updated by Loic Dachary 11 months ago

  • Status changed from Verified to Need Review
  • Assignee set to Loic Dachary

#7 Updated by Loic Dachary 11 months ago

This was not enough. Jenkins path to run tests is /home/jenkins-build/build/workspace/ceph-pull-requests/build (60 characters) so all tests have less than 47 characters to build a path such as src/test/testdir/test-7202/out/client.admin.25327.asok

#8 Updated by Loic Dachary 11 months ago

  • Subject changed from test/ceph_objectstore_tool.py fails in jenkins due to "The UNIX domain socket path" length limit to test fails due to "The UNIX domain socket path"

#10 Updated by Nathan Cutler 11 months ago

Couldn't the "ceph-pull-requests" component of the path be shortened, say, to "ceph-prs"?

#11 Updated by Loic Dachary 11 months ago

@Nathan that would help :-)

#12 Updated by Loic Dachary 11 months ago

  • Status changed from Need Review to Pending Backport

#13 Updated by Loic Dachary 11 months ago

  • Copied to Backport #18011: jewel: test fails due to "The UNIX domain socket path" added

#14 Updated by Loic Dachary 11 months ago

The source of the problem is http://tracker.ceph.com/issues/15249

#15 Updated by Nathan Cutler 9 months ago

  • Status changed from Pending Backport to Resolved

#16 Updated by Greg Farnum 4 months ago

  • Duplicated by Bug #19116: Sporadic segfaults in lockdep_locked on startup added

Also available in: Atom PDF