Project

General

Profile

Cleanup #15990

ceph-disk: expected systemd unit failures are confusing

Added by Loic Dachary almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
05/23/2016
Due date:
% Done:

0%

Tags:
Backport:
jewel
Reviewed:
Affected Versions:
Pull request ID:

Description

When activating a journal fails and later succeed (or the other way around), one of the two systemd unit is permanently marked as failed. This is confusing to the sysadmin who think there is a problem. This should be fixed.


Related issues

Copied to Ceph - Backport #17149: jewel: ceph-disk: expected systemd unit failures are confusing Resolved

History

#1 Updated by Nathan Cutler almost 3 years ago

@Loic: Which two systemd units are you referring to?

#2 Updated by Boris Ranto almost 3 years ago

@Nathan: He is talking about and for data/journal.

#3 Updated by Loic Dachary almost 3 years ago

Boris Ranto writes:

This could be fixed if we added 1 as an acceptable exit code for ceph-disk command, e.g. adding this line to the service file for ceph-disk:

SuccessExitStatus=1

We'd be just ignoring the error, though.

#4 Updated by Loic Dachary almost 3 years ago

That would be fine with me (forcing the exit code to always be a success). The problem is that it will also hide real errors. Some would say that there are so many level of indirections when / if ceph-disk prepare fails that it won't really make a difference (ceph-disk prepare creates a partition -> fires a udev event -> it triggers a systemd unit -> it runs ceph-disk activate fails because the journal is not there yet -> ceph-disk prepare creates the journal partition -> fires a udev event -> it triggers the systemd unit -> it runs ceph-disk activate does the job).

It's a judgement call really and I'm not sure what's best.

#5 Updated by Boris Ranto almost 3 years ago

Yeah, I was not too thrilled about it either. We might want to reserve a special exit code for saying 'not all devices ready' and ignore just that one?

#6 Updated by Boris Ranto almost 3 years ago

btw: If journal and data are on the same drive, this will be ok after reboot as both devices show up at pretty much the same time. However, it is still reproducible when installing the cluster as you first create and activate the journal partition and only then, few seconds later, you create the data partition. It would help a bit to create both partitions at the same time (or tell kernel to activate them at the same time, not one by one).

#7 Updated by Loic Dachary over 2 years ago

  • Priority changed from Normal to High

#8 Updated by Boris Ranto over 2 years ago

  • Assignee set to Boris Ranto

#9 Updated by Kefu Chai over 2 years ago

  • Status changed from New to Resolved

#10 Updated by Loic Dachary over 2 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to jewel

#11 Updated by Loic Dachary over 2 years ago

  • Copied to Backport #17149: jewel: ceph-disk: expected systemd unit failures are confusing added

#12 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF