Project

General

Profile

Bug #15715

rbd-nbd does not properly handle resize notifications

Added by Jason Dillaman about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/03/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The daemon attempts to listen for image header notifications to detect when an image has been resized. However, if the notification is delivered to the rbd-nbd client first before librbd, it won't be able to detect the size change since librbd just returns the old value.


Related issues

Copied to rbd - Backport #16735: jewel: rbd-nbd does not properly handle resize notifications Resolved

History

#1 Updated by Jason Dillaman about 3 years ago

  • Backport set to jewel

#2 Updated by Mykola Golub about 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Mykola Golub

#3 Updated by Jason Dillaman about 3 years ago

  • Status changed from In Progress to Need Review

#4 Updated by Mykola Golub almost 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #16735: jewel: rbd-nbd does not properly handle resize notifications added

#6 Updated by Loic Dachary almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF