Project

General

Profile

Bug #13560

unknown argument --quiet in udevadm settle

Added by Dietmar Maurer over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
10/21/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer,infernalis
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Seems 'rbd unmap' calls udevadm settle in krbd.c line 524:

} else {
/* * libudev does not provide the "wait until the queue is empty" * API or the sufficient amount of primitives to build it from.
*/
string err = run_cmd("udevadm", "settle", "--timeout", "10", "--quiet",
NULL);

When I run that command on a Debian Jessie standard installation I get
the following error:

  1. udevadm settle --timeout 10 --quiet
    Code should not be reached 'Unknown argument' at ../src/udev/udevadm-settle.c:87, function adm_settle(). Aborting.
    Aborted

There is no '--quiet' flag.


Related issues

Copied to rbd - Backport #13760: unknown argument --quiet in udevadm settle Resolved
Copied to rbd - Backport #13761: unknown argument --quiet in udevadm settle Resolved

Associated revisions

Revision 4300f2a9 (diff)
Added by Jason Dillaman over 3 years ago

krbd: remove deprecated --quiet param from udevadm

This parameter has been removed since systemd 213, so this
effects Fedora 21+, Debian Jessie, and potentially future
releases of RHEL 7.

Fixes: #13560
Backport: hammer, infernalis
Signed-off-by: Jason Dillaman <>

Revision 3d3595f8 (diff)
Added by Jason Dillaman over 3 years ago

krbd: remove deprecated --quiet param from udevadm

This parameter has been removed since systemd 213, so this
effects Fedora 21+, Debian Jessie, and potentially future
releases of RHEL 7.

Fixes: #13560
Backport: hammer, infernalis
Signed-off-by: Jason Dillaman <>
(cherry picked from commit 4300f2a9fe29627eea580564ff2d576de3647467)

Revision 497c1f06 (diff)
Added by Jason Dillaman over 3 years ago

krbd: remove deprecated --quiet param from udevadm

This parameter has been removed since systemd 213, so this
effects Fedora 21+, Debian Jessie, and potentially future
releases of RHEL 7.

Fixes: #13560
Backport: hammer, infernalis
Signed-off-by: Jason Dillaman <>
(cherry picked from commit 4300f2a9fe29627eea580564ff2d576de3647467)

History

#1 Updated by Jason Dillaman over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman over 3 years ago

  • Status changed from In Progress to Need Review
  • Backport set to firefly,hammer,infernalis

#3 Updated by Jason Dillaman over 3 years ago

  • Backport changed from firefly,hammer,infernalis to hammer,infernalis

#4 Updated by Loic Dachary over 3 years ago

  • Copied to Backport #13760: unknown argument --quiet in udevadm settle added

#5 Updated by Loic Dachary over 3 years ago

  • Copied to Backport #13761: unknown argument --quiet in udevadm settle added

#6 Updated by Jason Dillaman over 3 years ago

  • Status changed from Need Review to Pending Backport

#7 Updated by Mark Chaney about 3 years ago

Is there something holding this back from being backported? I can't remove remove any images until this is resolved for hammer on Debian Jessie.

#8 Updated by Nathan Cutler about 3 years ago

The hammer fix has been merged: https://github.com/ceph/ceph/pull/6530

It should be included in the 0.94.6 release.

#9 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF