Project

General

Profile

Bug #11197

pg stuck stale after create with activation delay

Added by Samuel Just over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
03/21/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
firefly
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

I think as soon as the mon gets a status from an osd(peering for instance), the pg moves off of the creating list and we stop sending creates. However, if the primary dies between sending that status and the replicas recording the initial activation, it will not have been written out on any other osd and will end up without any copies, yet not creating. As a bandaid, we can choose not to move it out of creating state until we activate?

(Not a hammer blocker, very very old bug as far as I can tell)

History

#1 Updated by Samuel Just over 3 years ago

  • Status changed from New to Testing

I'm somewhat wrong, the problem is that we don't set creating at all when handling the initial create message. It gets set on the first start_peering_interval after that point.

#2 Updated by Sage Weil over 3 years ago

  • Status changed from Testing to Pending Backport
  • Source changed from other to Q/A
  • Backport set to firefly

#4 Updated by Loic Dachary over 3 years ago

29bc9e5 PG: set/clear CREATING in Primary state entry/exit (in firefly),

#5 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF