General

Profile

Gaudenz Steinlin

Issues

Activity

01/31/2021

09:46 PM rgw Bug #47869: RGW Bucket Lifecycle configuration on non metadata master zones returns HTTP 503
The pull request was merged to master a few days ago. Would be nice to have a backport to Octopus for this. Should I ...

11/21/2020

09:31 PM rgw Bug #47866: Object not found on healthy cluster
I made some tests in our lab and can confirm the theory. I was able to reproduce this bug. I used the following setti...

10/15/2020

02:46 PM rgw Bug #22648: rgw: secondary site's lc configuration erased by multisite sync
I created https://tracker.ceph.com/issues/47869 for the issue described above.
02:45 PM rgw Bug #47869 (Resolved): RGW Bucket Lifecycle configuration on non metadata master zones returns HT...
We have a multi zonegroup RGW setup with two zonegroups in two different datacenter each with one zone. We choose thi...
09:54 AM rgw Bug #22648: rgw: secondary site's lc configuration erased by multisite sync
This issue is "fixed" in Octopus by commmit "d3fb699d6da8479a5e88207a9ae28a44122203b6", but forwarding to the metadat...

04/30/2020

02:40 PM rgw Bug #22648: rgw: secondary site's lc configuration erased by multisite sync
We have the same issue in an multi zonegroup configuration:
Ceph version: 13.2.8
Steps to reproduce:
1. create...

07/02/2019

01:11 PM RADOS Bug #23117: PGs stuck in "activating" after osd_max_pg_per_osd_hard_ratio has been exceeded once
Ceph version was 13.2.5 on the reinstalled host and 13.2.4 on the other hosts.
01:09 PM RADOS Bug #23117: PGs stuck in "activating" after osd_max_pg_per_osd_hard_ratio has been exceeded once
We also hit this problem with a cluster which had replicated pools with a replication factor of 3 and a CRUSH rule wi...

04/25/2019

02:56 PM rgw Backport #38713: mimic: rgw: gc entries with zero-length chains are not cleaned up
I would really appreciate a backport of this fix to Mimic. This is not only a cosmetic issue but if you have more tha...

01/07/2019

10:02 AM bluestore Bug #22464: Bluestore: many checksum errors, always 0x6706be76 (which matches a zero block)
The upgrade to 12.2.10 fixed the issue for us. See #65 for our setup. The most likely change in 12.2.10 which fixed t...

Also available in: Atom