Project

General

Profile

Bug #9994

ceph-qa-suite: nfs mount timeouts

Added by Greg Farnum almost 5 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
NFS (Linux Kernel)
Target version:
-
Start date:
11/03/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 55, in run_tasks
    manager.__enter__()
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/teuthology_master/teuthology/task/nfs.py", line 106, in task
    mnt
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/remote.py", line 128, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 364, in run
    r.wait()
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 105, in wait
    exitstatus=status, node=self.hostname)
CommandFailedError: Command failed on burnupi55 with status 32: 'sudo mount -o rw,hard,intr,nfsvers=3 plana21.front.sepia.ceph.com:/home/ubuntu/cephtest/mnt.0 /home/ubuntu/cephtest/mnt.1'

http://qa-proxy.ceph.com/teuthology/teuthology-2014-10-31_23:10:01-knfs-giant-testing-basic-multi/582461/

We've seen this elsewhere a few times, but it seems to be more consistent now (maybe just because we've resolved some of our other more common issues). I doubt it has anything to do with CephFS, but it's noisy in our nightlies.

History

#1 Updated by Greg Farnum almost 5 years ago

  • Subject changed from ceph-qa-suite: nfs mount timeouts (on mixed trusty tests?) to ceph-qa-suite: nfs mount timeouts

#2 Updated by Greg Farnum almost 5 years ago

teuthology-2014-11-03_23:10:01-knfs-giant-testing-basic-multi/585658/

#4 Updated by Greg Farnum over 4 years ago

teuthology-2014-12-17_23:10:01-knfs-master-testing-basic-multi/667121/
http://pulpito.ceph.com/teuthology-2014-12-17_23:10:01-knfs-master-testing-basic-multi/667116/

#5 Updated by Greg Farnum over 4 years ago

This continues to be a problem; e.g. http://qa-proxy.ceph.com/teuthology/teuthology-2015-01-11_23:10:01-knfs-next-testing-basic-multi/698898/

This one is trying to mount as nfs4 (the initial one is nfs3 though), I wonder if it could just be a symptom of incompatible protocols between client and server?

#10 Updated by Zheng Yan about 4 years ago

  • Status changed from New to Need Review

#11 Updated by Greg Farnum almost 4 years ago

  • Status changed from Need Review to Testing

#12 Updated by Greg Farnum over 3 years ago

  • Status changed from Testing to Resolved

Well, this hasn't been updated in a while, and the tests I really remember failing were all on OVH, which was resolved in that configuration setup. We can reopen if this pops up more.

Also available in: Atom PDF