Project

General

Profile

Bug #8458

`make check` should call tox tests for ceph-brag, ceph-disk, and ceph

Added by Alfredo Deza almost 10 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

100%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

There is a clear need for better testing in multiple Python environments (Ceph supports both 2.6 and 2.7) but
there are slight differences in both that may cause issues.

Issue #8321 showed one of these situations where lack of testing is causing breakage in some environments.

There is an initial implementation of that with tox and some packaging efforts for the brag-client, just for testing,
but there needs to be integration with the Makefile adding a make check target so that all further additions to
the python unittests through tox can be run.


Subtasks

Tasks #12037: Add unit/tox structure for ceph python scriptResolvedAlfredo Deza


Related issues

Related to devops - Bug #8321: ceph-brag missing a python dependency on EL6 Resolved 05/09/2014

History

#1 Updated by Loïc Dachary almost 9 years ago

  • Subject changed from implement tox tests for ceph-disk and ceph-brag to implement tox tests for ceph-brag

will open an issue for ceph-disk alone: they are different enough to not be bundled together

#2 Updated by Alfredo Deza almost 9 years ago

  • Subject changed from implement tox tests for ceph-brag to `make` should call tox tests for ceph-brag (and ceph-disk)

#3 Updated by Alfredo Deza over 8 years ago

We are still hitting issues because we aren't checking compatibility:

https://github.com/ceph/ceph/pull/4970

#4 Updated by Nathan Cutler over 8 years ago

  • Tracker changed from Fix to Bug
  • Project changed from Ceph to devops
  • Subject changed from `make` should call tox tests for ceph-brag (and ceph-disk) to `make check` should call tox tests for ceph-brag, ceph-disk, and ceph
  • Assignee changed from Alfredo Deza to Nathan Cutler
  • Regression set to No

#5 Updated by Nathan Cutler over 8 years ago

https://github.com/ceph/ceph/pull/1879 implemented the tox stuff for ceph-brag

#6 Updated by Nathan Cutler over 8 years ago

https://github.com/ceph/ceph/pull/4179 added the tox stuff for ceph-disk

#7 Updated by Nathan Cutler over 8 years ago

Added subtask http://tracker.ceph.com/issues/12037 to implement the tox framework for ceph

#8 Updated by Nathan Cutler almost 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF